cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
usher
New Member

badgateway

Hi,

I'm experiencing the bad gateway issue. My Flow is basically triggered when a list is modified and sends me an email. There are 3 steps.

1-When an item is created or modified in sharepoint site/list

2- Get entity values ( I want to get what has been changed)

3- Send an email

 

I know that step 1 and 3 work fine, cause I've tried them without step 2 and I get an email. But once I've added step 2 here is the "BADGateway

 

My first question is that once I create the second step (Get Entity Values) unlike the step 1 that gives me the drop down for site name and list name, this step doesn't give me an drop downs. So I have to manually populate them (entering site and list name). Fair enough I did. Is there a chance it can read site address and list name from previous step? (step 1)

 

- My other question is about "entity ID": what is entity id? I can see that I can populate that from the "add dynamic content" and also I can put the column headings from my list that are appearing in this drop down on the side. My gut feelings is that this is where it's failing. Please elaborate.

 

Thanks,

U

 

Outputs
Status code
502
Headers
{ "Pragma": "no-cache", "x-ms-request-id": "19876aeb-83df-4b5d-883c-d440dd4ace7a", "Timing-Allow-Origin": "*", "Cache-Control": "no-cache", "Date": "Fri, 08 Sep 2017 00:30:08 GMT", "Set-Cookie": "ARRAffinity=29bb95bbf65fa622a0d3263941bdae1045496bcfec1810ac1f7dcf5d9faf0b9b;Path=/;HttpOnly;Domain=sharepointonlineconnectionprovider-westus.tip0-westus.p.azurewebsites.net", "X-AspNet-Version": "4.0.30319", "X-Powered-By": "ASP.NET", "Content-Length": "342", "Content-Type": "application/json; charset=utf-8", "Expires": "-1" }
Body
{ "status": 502, "message": "Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx).\r\nclientRequestId: 19876aeb-83df-4b5d-883c-d440dd4ace7a", "source": "https://xxxxx.sharepoint.com/sites/analytics/_api/SP.APIHubConnector.GetEntityValues", "errors": [ "-1", "System.FormatException" ] }
1 REPLY 1
v-yamao-msft
Community Support
Community Support

Hi usher,

 

So far, the available documentation I have found about SharePoint site entity is:
https://msdn.microsoft.com/en-us/library/gg334637.aspx

 

From this documentation we know that the SharePoint site entity represents a location record in Microsoft Dynamics 365 that points to a site collection or a site on a server that is running SharePoint Server. The schema name for this entity is SharePointSite.

 

Another doc about the action “Get entity values” is:
https://docs.microsoft.com/en-us/connectors/sharepointonline/

 

But no more explanation on Entity Id.

 

I have tested the action on my side, the same issue with you. From the error message, it seems that the error is caused by the Entity Id. I will have to do further search on it. I will back once I got any updates.

 


Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (67,765)