cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
fess
Helper III
Helper III

files corrupted when sending multiple attachment in emails from sharepoint document library

i have followed the steps outlined here: https://powerusers.microsoft.com/t5/General-Power-Automate/Send-all-files-as-attachment-by-email-fro...

 

the files get sent but i cannot open them. there is some issue with encoding/decoding. could someone please help? i have checked all similar posts. thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
Paulie78
Super User
Super User

The files array is probably missing the content-type disposition and this corruption happens a lot. I wrote up a guide on my blog with the correct method for approvals and the send email action, have a read of that and see if it helps:

 

https://www.tachytelic.net/2020/09/power-automate-add-multiple-attachments-approval-email/ 

View solution in original post

2 REPLIES 2
Paulie78
Super User
Super User

The files array is probably missing the content-type disposition and this corruption happens a lot. I wrote up a guide on my blog with the correct method for approvals and the send email action, have a read of that and see if it helps:

 

https://www.tachytelic.net/2020/09/power-automate-add-multiple-attachments-approval-email/ 

@Paulie78 indeed, thank you!!

Helpful resources

Announcements
Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Users online (4,589)