cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper II
Helper II

flow has error, but it still run

I create a flow from tamplate : Save O365 email attachments to OneDrive for Business.

I run the flow, it has the error as attached photo.

But the attachments are still saving into the OneDrive for Business.

Why?ODB.JPG

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: flow has error, but it still run

Isn't that simply happneing by the first create file in your flow. That first create file look successful ( see green tick). All the grey crosses havn't run and are skipped as the run after settings are probably to only run on failure.

View solution in original post

3 REPLIES 3
Highlighted

Re: flow has error, but it still run

Isn't that simply happneing by the first create file in your flow. That first create file look successful ( see green tick). All the grey crosses havn't run and are skipped as the run after settings are probably to only run on failure.

View solution in original post

Highlighted
Community Support
Community Support

Re: flow has error, but it still run

Hi @JoeAu,

 

Do you use the "Save Office 365 email attachments to OneDrive for Business" built-in template to create your flow?

 

I don't think that your flow has errors. Actually, this built-in template flow adds a "Configure run after" action (Condition action) for the "Create file" action. 

 

I agree with @Pieter_Veenstra's thought almost, the Condition action would be executed when the "Create file" action failed within your flow. If the "Create file" action executes successfully, the below Condition action would be skipped. You could consider click Menu button-> "Configure run after" option to check the "Configure run after" action settings of the Condition action as below:4.JPG

 

5.JPG

 

 

More details about configuring a run after action after a failure of an action, please check the following blog:

Configure a run after action

 

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper II
Helper II

Re: flow has error, but it still run

 

Thanks Pieter

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (4,091)