cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Mrshahin
Level: Powered On

get-response

Hi Guy's,

 

We having a problem with one of our Flow's.

There is a network form that the HR using it to requeste a network access for our new users.

Since 2 weeks this Flow stop working and get this error:

 

InvalidTemplate. Unable to process template language expressions in action 'Get_response_details' inputs at line '1' and column '1842': 'Error reading string. Unexpected token: StartObject. Path 'queries.response_id'.'.

FlowError.JPG

 

Any Idea why the Flow stop working?

 

Thanks

 

11 REPLIES 11
Dual Super User
Dual Super User

Re: get-response

Hi, Can you share a screenshot of the flow (especially the part of Get Response Details action)

 

Thanks,

Mrshahin
Level: Powered On

Re: get-response

Thanks for your reply,

some of the section of Flow are not in english, sorry for that, If you like I can translate them for you.
This the Flow that we have a problem with:
FlowError2.JPG

 

Dual Super User
Dual Super User

Re: get-response

Hey!

 

Can you please do the following changes in the flow and check if that works: 

 

1. In the Apply to each action -> Get response Details action -> Response ID -> clear the value and select current Item from the dynamic values pane. 

 

(Kindly refer to the screenshot for a clear understanding)

 

tetete.png

Please mark this is as a solution if it solved your problem. 

 

Thanks,

Mrshahin
Level: Powered On

Re: get-response

We already did that, and it does not work yet,

Flowerror3.JPG

Dual Super User
Dual Super User

Re: get-response

You mind sharing the error screenshot post making these changes. 

 

Another thing I would suggest is to check the form availability once. Can you go to the forms portal and check if the form actually exists over there + check the form ID that you are using in the flow. 

 

Thanks,


@Mrshahin wrote:

We already did that, and it does not work yet,

Flowerror3.JPG


 

v-lin-msft
Level 10

Re: get-response

Hi @Mrshahin,

What are the types of form you use? Is it My forms, share with me, or Group forms?

After a simple test, it is possible to fill the form id with the irregular characters generated by the form, but the best method is to fill the form id with the form name of the drop-down list.

It is possible that your Form ID has changed. I advise you can fill in your Form ID by the ID corresponding to the Form name like this, rather than by the Form's direct ID, which may change as the Form content or time changes.Annotation 2019-05-27 132039.pngYou can have a try. If there is any problem, please contact us.

 

Best Regards,

Community Support Team _ Lin Tu

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Mrshahin
Level: Powered On

Re: get-response

unfortunatly right now I dont have access to the portal.

After get access to the portal I will keep you posted.

Thanks again

Highlighted
Mrshahin
Level: Powered On

Re: get-response

Sorry duplicate reply

Mrshahin
Level: Powered On

Re: get-response

tried your suggestion but still get the same error. 

Dual Super User
Dual Super User

Re: get-response

Hey! Can you post a screenshot of the error and the Flow.

 


Thanks, 

Mrshahin
Level: Powered On

Re: get-response

We get the same error as in my first post, and also in mt second post you can see the flow config.

let me know if like me to share more info.

 

Thanks

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (5,049)