cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BenRenshaw
Helper I
Helper I

isRequired Flag not working on Adaptive Cards

I understand that the adaptive card with version 1.3 has the isRequired:true tag, but I cannot use this as everytime I updated my version I get this message from Flow Bot... Is there any way around this? Thanks!

 

 

BenRenshaw_0-1599463297897.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
fchopo
Super User
Super User

Hello @BenRenshaw 

Adapative Cards version 1.3 are not supported by Bot Framework yet, so it's not possible to add cliente validation to the Adaptive Card. So the only solution I see is adding the validation in the flow at this moment.

Hope it helps!

Ferran

 

 

Did I answer your question? Please consider to mark my post as a solution to help others.
Proud to be a Flownaut!

View solution in original post

4 REPLIES 4
fchopo
Super User
Super User

Hello @BenRenshaw 

Adapative Cards version 1.3 are not supported by Bot Framework yet, so it's not possible to add cliente validation to the Adaptive Card. So the only solution I see is adding the validation in the flow at this moment.

Hope it helps!

Ferran

 

 

Did I answer your question? Please consider to mark my post as a solution to help others.
Proud to be a Flownaut!

@fchopo appreciate your response, definitely the correct answer. do you have any tips on adding the validation in the flow? Currently it is getting a name as a response and searching it through O365. Thanks for your help!! 

Hello @BenRenshaw 

Maybe you could validate whether it is empty or not, and then look for the user using "Search for users (V2)" action.

search.png

 

Hope it helps!

Ferran

Did I answer your question? Please consider to mark my post as a solution to help others.
Proud to be a Flownaut!

Hello @fchopo ,

I can understand how to use a Condition to validate a Card response but I assume that simply rejects a validation failure. Is there a method/Flow to ensure responses are valid and recipients cannot submit an invalid response (or they are Required to submit a valid response).
This question is to understand the work-around however I want to use a Input.ChoiceSet, where one option must be selected. The response must update my SharePoint list.
I hope you can help.

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (3,128)