cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
gjeh
Responsive Resident
Responsive Resident

no valid connection shared_sharepoint online

Hello all,

 

Today I tried editing an already existing flow which wrote data to excel to instead write that data to a sharepoint list.

So I went to sharepoint, created a new communication site, added a list in there with some colums.

In flow I created the Create Item block, selected the right subsite and the list name however i am receiving the following error:

shared_sharepoint.png

I've tried deleting the block and adding it back, after that I tried exiting my flow, going to Data > Connections and from there delete my Sharepoint connection and retry to create the flow. However the error persists.  Does anybody have a clue as to what might be the cause for this error? 

1 ACCEPTED SOLUTION

Accepted Solutions
gjeh
Responsive Resident
Responsive Resident

this was solved by having someone with admin rights import the flow. problems stemmed from the user roll person who imported it who did not have certain permission in sharepoint. 

View solution in original post

5 REPLIES 5
CFernandes
Super User
Super User

@gjeh I have seen this error from time to time and it resolves after clearing the browser cache. 

 

Could you try this after clearing your browser cache, or using another browser or in-private window?

 

v-litu-msft
Community Support
Community Support

Hi @gjeh,

 

Does your Flow still have the problems you face? 

Maybe it's a temporary problem. Just wait a little bit. If it still exists, please let us know, we will confirm it if is a bug.

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

gjeh
Responsive Resident
Responsive Resident

the problem is still in effect. can't use the flow even after deleting cookies and trying a different browser.

the more and more i use power platform the more i run into weird issues such as these where the cause is completely out of my controll and I am left at the business end of requests such as 'please wait a while'  'try recreating this 800 step flow from scratch' instead of 'this is the issue and this is how it can be fixed'.

 

v-litu-msft
Community Support
Community Support

Hi @gjeh,

 

Will the error report if you select the SharePoint site from drop-down?

If it could work, maybe this is the problem. You could select site from drop-down instead of custom value input.

If it couldn't work, you could consider using HTTP request to create item:

https://docs.microsoft.com/en-us/sharepoint/dev/sp-add-ins/working-with-lists-and-list-items-with-re...

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

gjeh
Responsive Resident
Responsive Resident

this was solved by having someone with admin rights import the flow. problems stemmed from the user roll person who imported it who did not have certain permission in sharepoint. 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (1,832)