cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
skelley523
Regular Visitor

null error on approval process

I have created an approval flow with a "when a new sharepoint item is added" trigger. I have also incorporated timeouts on each approval step. The flow executes all actions correctly but the flow "fails" with an error of "null". Has anyone else experienced this?

 

skelley523_0-1604420992707.png

 

1 ACCEPTED SOLUTION

Accepted Solutions

@skelley523 Your approval condition contains Responses, change that to Outcome and that should fix your issue. Sorry, I should have caught that in the first screenshot. 

If this reply answers your question or solves your issue, please ACCEPT AS SOLUTION ☑️. If you find this reply helpful, please consider giving it a LIKE. Want to know more? Follow @BradGroux on Twitter, and check out my Medium blog at https://msft.engineer.

 

View solution in original post

4 REPLIES 4
Brad_Groux
Super User II
Super User II

Without seeing the full error message we are basically spit balling. If you could provide an expanded screenshot and of any detailed error messages you're receiving we could likely better assist you. 

With that said, see - Common Errors Creating and Assigning Flow Approvals for some possible causes. I believe that if you change the Responses condition entry to Outcome you may clear this issue.

If this reply answers your question or solves your issue, please ACCEPT AS SOLUTION ☑️. If you find this reply helpful, please consider giving it a LIKE.

Here is the expanded screen shot. Really all is says is "null". I tried to use Outcome instead on approvers response and received  The execution of template action 'Apply_to_each_3' failed: the result of the evaluation of 'foreach' expression '@body('Start_and_wait_for_an_approval_from_Commissions_1_TIMEOUT')?['outcome']' is of type 'String'. The result must be a valid array.

skelley523_0-1604425238035.png

 

@Brad_Groux any suggestions

@skelley523 Your approval condition contains Responses, change that to Outcome and that should fix your issue. Sorry, I should have caught that in the first screenshot. 

If this reply answers your question or solves your issue, please ACCEPT AS SOLUTION ☑️. If you find this reply helpful, please consider giving it a LIKE. Want to know more? Follow @BradGroux on Twitter, and check out my Medium blog at https://msft.engineer.

 

View solution in original post

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MSFTBizAppsLaunchEvent

Experience what’s next for Power Virtual Agents

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Top Solution Authors
Users online (38,766)