cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jballesterosc
Regular Visitor

"Action 'Send_an_email_(V2)' failed" on Track Microsoft Forms responses in an Excel Online (Business) spreadsheet template

Hello, 

A couple weeks ago I created a flow from a template (Track Microsoft Forms responses in an Excel Online (Business) spreadsheet)  and everything was working fine. But a few days ago, the organization I'm working requested to update credentials. Since then, the flow is not working 100%. I tried to fix it by creating another one from scratch but the problem persisted. 

I have to notice that the condition is email's respondent is equal to email (this one is redundant, since the email's respondents 100% of the time is the email). 

 

Here's my flow after a test: 

 

Captura de Pantalla 2020-09-14 a la(s) 12.03.34.png

How can I fix this?

 

 

 

4 REPLIES 4
ChristianAbata
Super User
Super User

hi @jballesterosc  could you copy here the error message, could be some reasons, for example the email in field To is incorrect with white spaces o simeting like that



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA


@ChristianAbata wrote:

hi @jballesterosc  could you copy here the error message, could be some reasons, for example the email in field To is incorrect with white spaces o simeting like that


 

Thank you for answering, @ChristianAbata!

 

Here a better look of the error:

Captura de Pantalla 2020-09-14 a la(s) 18.31.20.png

 

Here the full text:

 

OpenApiOperationParameterTypeConversionFailed. The 'inputs.parameters' of workflow operation 'Send_an_email_(V2)' of type 'OpenApiConnection' is not valid. Error details: Input parameter 'emailMessage/To' is required to be of type 'String/email'. The runtime value '"anonymous"' to be converted doesn't have the expected format 'string/email'.


 

Anonymous
Not applicable

Hi @jballesterosc could you please provide a picture of your flow in Edit mode? Lets see the dynamic content that is being used by on the "To" parameter of the email.

 

Thank you.

Of course, @Anonymous. Thank you for your answer!

 

I attach the photos in order:

 

Captura de Pantalla 2020-09-15 a la(s) 9.36.40.pngCaptura de Pantalla 2020-09-15 a la(s) 9.38.24.pngCaptura de Pantalla 2020-09-15 a la(s) 9.40.15.pngCaptura de Pantalla 2020-09-15 a la(s) 9.41.59.png

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Users online (4,854)