cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Kudo Kingpin
Kudo Kingpin

"ActionBranchingConditionNotSatisfied. The execution of template action 'Send_an_email' skipped:

Receiving the above error when trying to create a workflow, does anyone know why this is happening? 

 

Error message: ActionBranchingConditionNotSatisfied. The execution of template action ': the branching condition for this action is not satisfied.

 

Send_an_email skipped.png

 

 

 

 

 

4 REPLIES 4
Highlighted
Anonymous
Not applicable

Re: "ActionBranchingConditionNotSatisfied. The execution of template action 'Send_an_email' ski

Just from looking, I don't see what the Condition is trying to evaluate. Maybe that's embedded in the "Send email with options" step, but the error message, to me, seems to indicate it's failing because it cannot determine which branch to take. So it doesn't know whether the condition is True or False.

Highlighted
Kudo Kingpin
Kudo Kingpin

Re: "ActionBranchingConditionNotSatisfied. The execution of template action 'Send_an_email' ski

Please see attached - condition is looking for Approve value from email with options response. 

Inkedcondition-email skipped_LI.jpg

 

 

 

Highlighted
Anonymous
Not applicable

Re: "ActionBranchingConditionNotSatisfied. The execution of template action 'Send_an_email' ski

When I put "Approve" in quotes I got the problem you had. When I took quotes off Approve it ran correctly. Also when I look at the Advanced Mode of the Condition it shows @equals(body('Send_email_with_options')?['SelectedOption'], 'Approve')Capture1.PNG

Highlighted
Community Support
Community Support

Re: "ActionBranchingConditionNotSatisfied. The execution of template action 'Send_an_email' ski

Hi @Basic_User007,

 

I think you should not consider the scope of the content of the action output.

If you want to configure the Condition using the output of Send email with option, you should configure the Condition in Apply_to_each so that you can evaluate the formula by relying on the output of Send email with option.

Like:

59.PNG

Please provide more details about your Flow configuration, if you need further suggestion to refine your Flow.

 

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (7,137)