cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
siimgorczyca
Frequent Visitor

"Create flow" action resulting in an error

I'd like to provision power platform archiving based on the CoE solution. I was able to export a given power app or flow, I can import a power app back, but when I want to import the flow, I end up with errors. The automatic export saves two files in a SP library - definition.json and connectionreferences.json. If using the "Create flow" action I try to create a new one based on the files, I can only succeed if the connections are for the same user and environment (which does not make sense since the archiving solution is organisation-wide). So I wanted to bypass the connectionreferences, but when I only give the definition.json content, I get the error below:

 

Flow save failed with code 'WorkflowRunActionInputsInvalidProperty' and message 'The 'inputs' of workflow run action 'Get_Flow' of type 'OpenApiConnection' should not have the property 'authentication'.'.

 

I thought that might be caused by some kind of data type issue or whatever, so I tried to simply make a copy of an existing flow by fetching its details using the "Get Flow" action and passing its data to the "Create Flow" action - but that results in an identical error. Am I doing something wrong here or is this caused by a recent update in the "Create Flow" action?

2 REPLIES 2
Brad_Groux
Super User II
Super User II

Ensure that you have all of the proper credentials in use for each of the steps within the imported flow under the My Connections area:

SharedMailboxAccountSelection.png

If you could provide an expanded screenshot of your Flow and steps, your Flow run history, and of any detailed error messages you're receiving we could likely better assist you. Also, for the best results, you may want to review How to write a good forum post.

If this reply answers your question or solves your issue, please ACCEPT AS SOLUTION ☑️. If you find this reply helpful, please consider giving it a LIKE. Want to know more? Follow @BradGroux on Twitter, and check out my Medium blog at https://msft.engineer.

siimgorczyca
Frequent Visitor

Hi @Brad_Groux,

the connections are set correctly, the error details are in the original post, but as requested, I am putting the screenshots here.

The whole flow is very simple, I just get the details of an existing flow from one environment and then want to create a copy in another environment.


flow.png

 

 And this is the response I get with from the Create Flow action.

createflow.PNG

 

If I put anything in the connectionReferences field, I get a different error. Our goal is to create the flow from a definition.json file uploaded to a SP library, but it doesn't work either, so tried with a more simple approach first.

Helpful resources

Announcements
User Groups Public Preview

Join us for our User Group Public Preview!

Power Automate User Groups are coming! Make sure you’re among the first to know when user groups go live for public preview.

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Users online (26,836)