cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ct_klein
Frequent Visitor

"No dependent actions succeeded" return from Flow

Hello,

I am relatively new to Flow and I have a 'simple' task that I just cannot figure out.

I'm connecting to Dynamics 365, using CDS.

I have an entity which has a createdon date.

I want to set the status of an entity record to expired if it is older than 120 days.

I added a 'List records' action, just selecting the entity I want with no other changes.  There are only 408 records in my testing data

listrecords.jpg

The next step was the condition, and after some searching I came up with this.

Accepting the 'Output' from the list records, the Condition is:

CreatedOn is less than or eq addDays(utcNow(),-120,'dd/MM/yyyy')

 

If it meets that criteria 'If Yes' I have 'Update a record'.

Environment and Entity name match the list records action and the 'Record Identifier' is set to Current Item.

The only thing I am updating is the entity field 'Status Reason Value' to Expired, which I selected from the dropdown on the field.

 

It runs and I get the following:

Action 'Condition' failed

An action failed. No dependant actions succeeded.

In the Update a record action I have a bad request.

Statuscode: 400

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN""http://www.w3.org/TR/html4/strict.dtd">
<HTML><HEAD><TITLE>Bad Request</TITLE>
<META HTTP-EQUIV="Content-Type" Content="text/html; charset=us-ascii"></HEAD>
<BODY><h2>Bad Request - Invalid URL</h2>
<hr><p>HTTP Error 400. The request URL is invalid.</p>
</BODY></HTML>

 

Sorry for the longish post but does anyone have any idea why this is failing?  

 

1 ACCEPTED SOLUTION

Accepted Solutions
Super User
Super User

Re: "No dependent actions succeeded" return from Flow

Hi @ct_klein 

 

Here it is from solution create flow. Search for common data service default

 

image.png

 

Click the second one from the list (Common Data Service Default Environment)

 

Select List Records.

image.png

 

Above you can see the FetchXML Query option.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

View solution in original post

10 REPLIES 10

Re: "No dependent actions succeeded" return from Flow

@ct_klein - I would suggest using the "Common Data Service (current environment)" connector. This can only be done when a flow is created within a Solution file.

 

By using this connector, there is an option in the "List Records" action called "Fetch XML". Since you are using Dynamics 365, you can do a quick Advanced Find to Pricing records older than 120 days and they aren't flagged as "Expired". Within the Advanced Find window there is a "Download Fetch XML" button. Open this is notepad and copy the fetch xml. Then, paste this into the "Fetch XML" field in the "List Records" action. 

 

This can save you having to using the Condition. 

ct_klein
Frequent Visitor

Re: "No dependent actions succeeded" return from Flow

The 'List records' from CDS is what I showed, I dont see a 'Fetch XML' option in there, just the filter.

I do have the fetch xml that I would paste in there:

<fetch version="1.0" output-format="xml-platform" mapping="logical" distinct="false">
<entity name="ct_pricing">
<attribute name="createdon" />
<attribute name="ct_pricingid" />
<attribute name="statuscode" />
<order attribute="ct_pricesetid" descending="false" />
<filter type="and">
<condition attribute="createdon" operator="olderthan-x-months" value="4" />
</filter>
</entity>
</fetch>

Just not sure where it goes.

 

thanks!

 

Super User
Super User

Re: "No dependent actions succeeded" return from Flow

Hi @ct_klein 

 

Create a solution. Create flow. Then search for Common Data Service Default Environment. Select that connector. You can see the FetchXML option there.

 

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

Re: "No dependent actions succeeded" return from Flow

@ct_klein - As I mentioned in the beginning of my prior post, the flow has to be created from within a solution. This is what @abm mentions. Then you will see the field for the "Fetch XML".

ct_klein
Frequent Visitor

Re: "No dependent actions succeeded" return from Flow

Yes, I went into the pricing entity, clicked on flows, created a new flow, comes up with a screen where I am going to be creating a Common Data Service Button.  The first action is 'When a record is selected', choose environment and entity.  I add an action for 'List records' and there I dont see a Fetch XML option, nor does Fetch XML show up if I search for it.

Sorry if I'm being dense here.

Super User
Super User

Re: "No dependent actions succeeded" return from Flow

Hi @ct_klein 

 

Here it is from solution create flow. Search for common data service default

 

image.png

 

Click the second one from the list (Common Data Service Default Environment)

 

Select List Records.

image.png

 

Above you can see the FetchXML Query option.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

View solution in original post

ct_klein
Frequent Visitor

Re: "No dependent actions succeeded" return from Flow

From the Solution, create a flow.  This is what I get, I do not have the 2nd 'Common Data Service Default Environment'

cds.jpg

Super User
Super User

Re: "No dependent actions succeeded" return from Flow

Thats strange. Just type Common Data and see



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
ct_klein
Frequent Visitor

Re: "No dependent actions succeeded" return from Flow

yeah, only the one shows up.

Highlighted
ct_klein
Frequent Visitor

Re: "No dependent actions succeeded" return from Flow

So as an update, I was in the wrong solution.  I was coming in from Dynamics 365->Solutions instead of Powerapps->Solutions->Select a Solution

 

Thanks for the help!

 

Helpful resources

Announcements
firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Automate Community!

firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Community Summit North America

The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Users online (8,448)