cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Apetrushenko
New Member

"Start and wait for an approval"/"Start and wait for an approval (V2)" don's send email notifications

I have  added both of this actions, and both of them don't send notifocations. Only messages in Approval portal.

On the other hand at my test environment (another Office 365 tenant) email notification are sending.

What can be a difference?

6 REPLIES 6
efialttes
Super User
Super User

@Apetrushenko 

Can you share an screenshot of your flow and the way you filled inputs in "Start and Wait for an approval" action block?

Thankx!



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Hi! You can find screenshot here.

@Apetrushenko 

Thankx! So no approval email is received at "Created by" email address, right?

 



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



v-yamao-msft
Community Support
Community Support

Hi @Apetrushenko ,

 

Thanks for sharing the screen shot.

 

As you mentioned you could check the approval request under Approvals center, but there is no message sent to the email box.

 

Will it work if you send the approval email to your own email box?

 

Please make sure the creator’s mail box doesn’t have any restrictions on emails from flow.

 

Could you share more details on the environment that doesn’t work?

 

When testing the two approval actions, both are working properly on my side.

 

Best regards,

Mabel  

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks for this!

I have investigated this issue more deeply and found, that this is a problem with domain of the user.

Our environment has 2 domains, for examle:

user1@domain1.ie

user2@domain1.ie

user3@domain1.ie

and

user1@domain2.ie

user2@domain2.ie

 

Flow is running under user1@domain1.ie.

Users: user2@domain1.ie and user3@domain1.ie - receiveng approval email notifications.

Users : user1@domain2.ie and user2@domain2.ie - do not receive approval email notifications.

 

If I send email using outlook from user1@domain1.ie to users user1@domain2.ie and user2@domain2.ie  messages are delevering fine.

But approvals notifications not....

Which setting should I check to be sure, that users in domain2.ie can receive approval notifications?

Many thanks!

 

 

@Apetrushenko 

HAve you considering using "Send email with options" instead? Or at least to doubleckeck if emails generated with this workaround reach both domains

Hope this helps



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Users online (1,437)