cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MiRA0001
Regular Visitor

"The given key was not present in the dictionary" while updating

Hello,

 

I'm trying to update a few lookups I have in an custom entity using an automatic cloud flow triggered by update/creation.

I get the list of rows and then I perform the update inside an apply to each block, but somehow the update operations work for certain rows but not for the other ones. From a list of 7 objects 3 of them are failing and is always the same 3. I can't see any different between the ones that fail and the ones that are not. 

 

The error is "The given key was not present in the dictionary"

 

Can someone give me a clue about why this is happening so I can fix it? Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Mira_Ghaly
Dual Super User
Dual Super User

@MiRA0001 

This error can be a result of a synchronous plugin running on the update of the record, so you need to check what are the plugins registered on this entity on the Update Event , To be able to do this you need to Use the Plugin Registration Tool on the XRM ToolBox, Click on View , Display by Entity

Mira_Ghaly_0-1639603913885.png

Expand your Table , and you can see what is running on the Update Message:

Mira_Ghaly_1-1639603963064.png

Most probable the code in the plugin is looking into some value that is not supplied by your Update step in the flow. 

Let me know if this helps or you need more help around this!

 

 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

View solution in original post

1 REPLY 1
Mira_Ghaly
Dual Super User
Dual Super User

@MiRA0001 

This error can be a result of a synchronous plugin running on the update of the record, so you need to check what are the plugins registered on this entity on the Update Event , To be able to do this you need to Use the Plugin Registration Tool on the XRM ToolBox, Click on View , Display by Entity

Mira_Ghaly_0-1639603913885.png

Expand your Table , and you can see what is running on the Update Message:

Mira_Ghaly_1-1639603963064.png

Most probable the code in the plugin is looking into some value that is not supplied by your Update step in the flow. 

Let me know if this helps or you need more help around this!

 

 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (2,932)