cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper II
Helper II

simple approval flow with list copy failing to update one column

Hi Team

I have created a simple approval flow.

Capture.JPGCapture1.JPGCapture2.JPG

Item is added to list:
LaptopsToAdd
A soon it`s approved the item is copied to the second list
LaptopsToAddTest

And that is working fine. What I also would like to do is to come back to list LaptopsToAdd and update column who approve this item.

Don`t know why flow updates this column but for the previous add item not for the current. for example, if I add one after another 
Laptop1

Laptop2

The approval column will be not updated for the Laptop1 and the after adding Laptop2 it will update the column for Laptop1 but should for Laptop2 no so on 

Capture3.JPG

1 ACCEPTED SOLUTION

Accepted Solutions
Super User III
Super User III

@m0le:

 

I suspect that the ID you are referencing in your Update Item action is from the Create Item action immediately before it rather than from the When an Item is Created trigger.  Please take a look at your Flow and verify that you are referencing the correct ID.

 

If this solves your issue, please mark your post as Solved.

 

Scott

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

View solution in original post

2 REPLIES 2
Super User III
Super User III

@m0le:

 

I suspect that the ID you are referencing in your Update Item action is from the Create Item action immediately before it rather than from the When an Item is Created trigger.  Please take a look at your Flow and verify that you are referencing the correct ID.

 

If this solves your issue, please mark your post as Solved.

 

Scott

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

View solution in original post


@ScottShearer wrote:

@m0le:

 

I suspect that the ID you are referencing in your Update Item action is from the Create Item action immediately before it rather than from the When an Item is Created trigger.  Please take a look at your Flow and verify that you are referencing the correct ID.

 

If this solves your issue, please mark your post as Solved.

 

Scott


Ha! you right, thanks

Helpful resources

Announcements
PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Users online (4,075)