cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

ui flow login

Hi, 

On this website https://docs.microsoft.com/en-us/power-automate/ui-flows/create-web it says:

Temporary user profile for playback

Selenium IDE recordings are done with the current user's profile, but playback is done using a temporary user profile. This means that websites that need authentication may not ask for credentials during a recording session, but the authentication steps will be needed during playback.

To address this, the user needs to manually edit the script to insert the commands needed for the login process.

I am struggling exactly with this. 

 

After building my webapp flow, I tested everything in Selenium IDE where things work perfectly. 

I even made sure that I am logged out from any website/application when I recorded my webapp flow. 

In other words, my webapp tests open a website where Selenium logs in and then executes the steps. 

So far so good. 

 

Problem:

If I add my webapp flow into a normal one then the login does not work. 

There seems to be a refresh of the login page and things get stuck immediately. 

 

Can somebody provide some hints how to overcome this issue?

 

Many thanks, 

 

Ludwig

1 ACCEPTED SOLUTION

Accepted Solutions
v-litu-msft
Community Support
Community Support

Hi @lreinhard7,

 

The browser you tested before was successful because it cached your authentication and password, so when you tested the UI Flow, you could use the information you already had. But testing in a normal one (presumably a new browser) results in an error because the authentication information is gone, or because there is no way to invoke the information.

 

The UI Flow still in preview, it still some limitation exist and some feature need to perfect, please pay attention to wait it rolling out.

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

5 REPLIES 5
v-litu-msft
Community Support
Community Support

Hi @lreinhard7,

 

The browser you tested before was successful because it cached your authentication and password, so when you tested the UI Flow, you could use the information you already had. But testing in a normal one (presumably a new browser) results in an error because the authentication information is gone, or because there is no way to invoke the information.

 

The UI Flow still in preview, it still some limitation exist and some feature need to perfect, please pay attention to wait it rolling out.

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

@v-litu-msft 

 

Any update about this? Or an recomendation?

 

I need this to access to http://web.whatsapp.com without loggin all times

 

Thanks!

I'm also interested in best practices for handling login steps.   In production state, the need would be have an end user  send a file from SharePoint to "System X", where the credentials for System X might be the same as for SharePoint or different.  It seems like the flow would need to have logic to enable the user to login to System X if they are not already, to then continue the automated process.  

This is still not fixed, even when running the Web UI flow in attended mode.

Anonymous
Not applicable

Any update on this?

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (46,635)