cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
pr0g
Level: Powered On

A bug has occurred since the last version of powerapps (3.19052.19)

Hello,

 

A bug has occurred since the last version of powerapps (3.19052.19)

 

Since the last update, my entire application is no longer working.
The Fields displaying the information from the selected item in the gallery no longer display anything or display data from another item.
From now on, there is a problem with Gallery.selected and I do not know why ...
is there a way to fix it?


Thank you

1 ACCEPTED SOLUTION

Accepted Solutions
PowerApps Staff _Corey_
PowerApps Staff

Re: A bug has occurred since the last version of powerapps (3.19052.19)

Final update: A hotfix to address the issue has been successfully deployed. The updated Studio version is v3.19052.20.115177617. You will need to edit your app(s) in Studio and re-publish for the fix to take effect--please remember that it make take up to a few minutes for the newly published app(s) to be packaged and available to players (web or mobile). Please report any issues you experience with this update.

Once again, we are sorry for any inconvenience this has caused.

View solution in original post

71 REPLIES 71
karacsondi
Level: Powered On

Re: A bug has occurred since the last version of powerapps (3.19052.19)

We are experiencing absolutely the same issue, and it can be reproduced easily in a 'from scratch' app as well - see the screen capture attached.

QJappie22
Level 8

Re: A bug has occurred since the last version of powerapps (3.19052.19)

PowerApps Staff _Corey_
PowerApps Staff

Re: A bug has occurred since the last version of powerapps (3.19052.19)

@pr0g @karacsondi @QJappie22 As mentioned on other threads, we have identified the issue and we are actively working on a hotfix.  We will keep the thread posted as we know more.  Sorry for any inconvenience.

PowerApps Staff _Corey_
PowerApps Staff

Re: A bug has occurred since the last version of powerapps (3.19052.19)

Update: A hotfix has been validated and is approved for deployment. Once deployed, you will need to edit your app(s) in Studio and re-publish. I will update this thread once hotfix deployment is complete.

Highlighted
Community Support Team
Community Support Team

Re: A bug has occurred since the last version of powerapps (3.19052.19)

HI @pr0g ,

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned.

 

Please consider restore your app to previous version, and run your app again, then check if the issue is solved.

More details about restoring app to previous version, check the following article:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/restore-an-app

 

Also please consider re-generate a new app based on your data source, then check if the issue still exists. If the issue still exists, please consider submit an assisted support ticket through the following link:
https://powerapps.microsoft.com/en-us/support/pro

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Sijts
Level 8

Re: A bug has occurred since the last version of powerapps (3.19052.19)

The phone layout still has the bug at this point.

What you experienced is maybe that the tablet version is working correctly, noticed this yesterday

@v-xida-msft 

Raynok1
Level 8

Re: A bug has occurred since the last version of powerapps (3.19052.19)

Hi There,
Using : Phone layout

I've have the exact same problem, my app is completely broken across multiple tenants. Which means its not something I changed or done wrong. The browser gallery select doesn't display data on the next screen. 

1.) Restored the app from 2 weeks ago but its still broken.

2.) Created a new app from scratch using the same data source, the issue still persists.

3.) Created a text label to CountRows(BrowseGallery1.AllItems) which works but if I search for items the count doesn't change until the last ")" is removed and re-added. However that is still broken because I have to repeat this process just to see the number change. Its broken.

 

In the last 2 days the app has been rolled out to -+ 230 individuals and last evening and today its not working. Its embarrassing(LoL) because its the first introduction of powerapps to the company. I tell you, Murfy's law is at play here. 

I've tried every possible test, from data to app logic to rebuild and restore, its broken. Help.

Kind Regards,

Rayno

Raynok1
Level 8

Re: A bug has occurred since the last version of powerapps (3.19052.19)

@_Corey_ @v-xida-msft  : Just a reminder for informing us once the deployment fix rollout is complete. 
Kind Regards,

Rayno

Liliana1210
Level: Powered On

Re: A bug has occurred since the last version of powerapps (3.19052.19)

I have exactly the same issue - items in another gallery or form no longer update when a new item is selected from the original gallery. 

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (4,699)