cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ccernat_23
Level: Powered On

Application completely broken - The app didn't start correctly. Try refreshing your browser.

Hello!

 

Weirdest thing. I have 2 applications, one for mobile, one for tablet / pc in terms of screen size. They worked perfectly for months. They are mirroring each other in terms of functionality and business logic, apart for design, objects used.

 

Today, I wanted to enter in edit mode for the Desktop one: it is a total mess, objects moved ( labels, forms, etc, weird * appeared near data cards ).

 

I  tried to open it: The app didn't start correctly. Try refreshing your browser. Session ID: b37f3b05-9b02-422e-a3fc-670cea9b07bb

 

The other one, the mobile one, is working perfectly. In edit mode as in play mode.

 

I tried to restore with some versions of it from 2 months ago, same erratic behavior: not working in play mode, the same complete mess in edit mode.

 

Does anyone have any idea what is going on? Can someone from the support team take a look at the session ID?

 

Thank you very much!

 

3 REPLIES 3
Community Support Team
Community Support Team

Re: Application completely broken - The app didn't start correctly. Try refreshing your browser.

Hi @ccernat_23 ,

Could you please share a bit more about the issue that you mentioned?

Do you mean that you could not edit your app in PowerApps Sutdio?

 

I have made a test on my side, and don't have the issue that you mentioned. Based on the issue that you mentioned, I think this issue may be related to the PowerApps version 3.19052.19. There have already some other users faced similar issue with you about the PowerApps app rendering issue when using PowerApps version 3.19052.19.

Please check the response within the following threads for more details:

https://powerusers.microsoft.com/t5/General-Discussion/A-bug-has-occurred-since-the-last-version-of-...

https://powerusers.microsoft.com/t5/General-Discussion/Gallery-control-broken/m-p/289520#M83641

 

Now, PowerApps has released a new version - 3.19052.20. These issues occured within PowerApps 3.19052.19 has been fixed.

On your side, please consider made some changes to your app, then re-publish your app, check if the issue is solved.

Also please consider turn off the "Improved app rendering (final validation)" option within Advanced settings of App settings of your app, then re-load your app, check if the issue has been fixed.

 

If the issue still exists, please consider re-create a new app based on your data source using latest version of PowerApps Studio, then check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
ccernat_23
Level: Powered On

Re: Application completely broken - The app didn't start correctly. Try refreshing your browser.

The issues are still here. Tried everything ( made changes, saved, published, disabled Improved app rendering ) apart from re-creating the application. The Live published app version is now 3.19053.21

 

1. The app doesn't load - the same message when I want to Play it: The app didn't start correctly. Try refreshing your browser. Session ID: 3ec513ca-2cb9-434f-9a63-2754af7c19e6

 

2. When I want to Edit it: the same complete mess with the rendering of galleries, controls, etc. Bellow a simple label control, completely messed up... 😞

 

err_papp.JPG

 

Now, what did you mean by re-creating the app? It has tens of screen, do you mean to actually re-do all the development? This is days of work. Or I misunderstood your suggestion? 

 

Please help.

ccernat_23
Level: Powered On

Re: Application completely broken - The app didn't start correctly. Try refreshing your browser.

Is it possible to give you the .zip package?

 

It is so frustrating. Whatever I create in it, while in Edit mode, with the app completely messed out, it doesn't work: simple labels, text inputs. After saving and publishing, they all get broken.

 

What is going on @v-xida-msft? I cannot just simple re-do all the development and create a new app. Is there a formal channel for my organization to contact MS support for this issue?

 

Thank you so much!

 

 

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (4,559)