cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
rheid
Level: Powered On

BUG: PowerApp SharePoint List Form not refreshing anymore

Hi PowerApps Team, I have an important problem with SharePoint PowerApps Forms.

They no longer update the values in the from of a list (see Video / see Screen).  The problem is new a few days ago everything was still fine. If I reload the complete page in the browser, the form is ok again. Smiley Sad

 

What can I do? Same on all browsers and operating systems.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User
Super User

Re: BUG: PowerApp SharePoint List Form not refreshing anymore

@rheid 

Yes I see that the old fix is still effective for one thing, but there appears to be a newer problem that has developed.  I am not sure that it is a known issue though.  @Pstork1 can you site something that shows it to be a known issue before I duplicate an escalation?

 

A quick fix to the issue is to put another Refresh statement in the OnEdit action of your SharePointIntegration object.

On a default customized form that would be : Refresh(yourList); EditForm(SharePointForm1)

You might also want to put this in the OnView action of the integration as well since the view state of the form exhibits the same issue.

That cleared it up on my side.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.

View solution in original post

16 REPLIES 16
rheid
Level: Powered On

Re: BUG: PowerApp SharePoint List Form not refreshing anymore

Here found a video about the problem: https://youtu.be/9YqOx5hTmuk


@rheid wrote:

Hi PowerApps Team, I have an important problem with SharePoint PowerApps Forms.

They no longer update the values in the from of a list (see Video / see Screen).  The problem is new a few days ago everything was still fine. If I reload the complete page in the browser, the form is ok again. Smiley Sad

 

What can I do? Same on all browsers and operating systems.


 

Super User
Super User

Re: BUG: PowerApp SharePoint List Form not refreshing anymore

@rheid 

Please take a look at this post in regard to that.  There is a quick change that will resolve it.

 

I hope that helps you.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.
rheid
Level: Powered On

Re: BUG: PowerApp SharePoint List Form not refreshing anymore

@RandyHayes Thanks for your super fast message Cat Very Happy. I tried it right away. Unfortunately it didn't bring any improvement. Do you have any other idea what I could do? All lists in the site collection are affected no matter what I do.

Dual Super User
Dual Super User

Re: BUG: PowerApp SharePoint List Form not refreshing anymore

MS is aware of this and is looking into it.  Try one more thing that they say works in the meantime.  access a different item and then go back to the original.  At that point the original will update.  It seems to be a problem with the form caching values.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
Highlighted
Super User
Super User

Re: BUG: PowerApp SharePoint List Form not refreshing anymore

@rheid 

Yes I see that the old fix is still effective for one thing, but there appears to be a newer problem that has developed.  I am not sure that it is a known issue though.  @Pstork1 can you site something that shows it to be a known issue before I duplicate an escalation?

 

A quick fix to the issue is to put another Refresh statement in the OnEdit action of your SharePointIntegration object.

On a default customized form that would be : Refresh(yourList); EditForm(SharePointForm1)

You might also want to put this in the OnView action of the integration as well since the view state of the form exhibits the same issue.

That cleared it up on my side.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.

View solution in original post

rheid
Level: Powered On

Re: BUG: PowerApp SharePoint List Form not refreshing anymore

@RandyHayes Good work! OnEdit action: Refresh(yourList); EditForm(SharePointForm1)

load now the form in 99% correct.

 

My SharePoint Integration had no refresh by default. Should that be the case? Maybe there is a problem? the microsoft builder has missed this step?

 

The applications were all created yesterday.

Super User
Super User

Re: BUG: PowerApp SharePoint List Form not refreshing anymore

@rheid 

*Normally* the SharePointIntegration does not need to be refreshed like that - thus it would not be in the designer by default.  However, there has been an issue for a while now that first surfaced with the forum positing that I linked for you in the first reply.  That was unusual to have to add that refresh.  But, not it seems worse that you even have to refresh when the form is brought up for any action (OnEdit, OnView, etc).  That is something that should be resolved in the SharePointIntegration and not something that you have to add.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.
rheid
Level: Powered On

Re: BUG: PowerApp SharePoint List Form not refreshing anymore

@RandyHayes Thanks again for the quick support. We have these forms in production. If the wrong values are displayed here we would have big problems 


Super User
Super User

Re: BUG: PowerApp SharePoint List Form not refreshing anymore

@rheid 

Yep...it's a big problem.  That's why I'd like to get confirmation from @Pstork1 that this particular one is a referenced known issue.

It's good we have a workaround, but not everyone is going to read this posting.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 345 members 5,740 guests
Please welcome our newest community members: