cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Super User
Super User

BUG - Radio button does not show any selection when value changes

Hi all,

 

Let's see if I can put into words what goes on (I will attach an animated GIF also):

 

In my form I have two radio buttons for Yes/No (Ja/Nej). When I click on a person in the app for the first time the radio button's value updates OK. When I select another person, the radio buttons show the correct value only if the underlying value is also changed. If person 2's value is the same as person 1's, no radio button will the selected! Needless to say, this is very annoying (as yet I said it!).

 

Hope this can be fixed soon as the app will go live in a week or two.

 

EDIT - I put radio buttons on the main screen and not in the form and connected them to the gallery's selection.When doing that, the radio buttons always displayed the correct data, so it seems it's a problem with the radio buttons and the form.

 

4 REPLIES 4
Super User
Super User

Re: BUG - Radio button does not show any selection when value changes

So I did a test app, using the same on prem SQL-data.

 

The gallery is on the left hand side. On the right hand side there are three areas:

  • one with a label and two radio buttons
  • one with a view form
  • one with an edit form

In the video I click items in the gallery and notice the following:

  • When changing item in the gallery, the first two areas updates OK all the time
  • For the view form, when the value (Publiceringsratt) doesn't change value from one item to the other, the radio buttons won't show a selection

 

This shows that the problem is related to radio buttons in edit forms.

grodinsm
Level: Powered On

Re: BUG - Radio button does not show any selection when value changes

We have the same problem, it's a frustrating bug. We implemented an 'autosave' on our form because some staff were leaving it open forever and forgetting to save, and came across this issue. (save and close apparently works fine, just "save" in the form causes the data loss). 

 

also came across this thread, same issue:

https://powerusers.microsoft.com/t5/General-Discussion/Radio-Buttons-not-displaying-Data-Card-Value-...

 

 

Administrator
Administrator

Re: BUG - Radio button does not show any selection when value changes

@BitLord69 @grodinsm thanks for sharing this, and a ticket will be created for this. I will update you as soon as I hear anything.

Highlighted
Super User
Super User

Re: BUG - Radio button does not show any selection when value changes

Any updates on this? Users are going crazy over this bug, they think they ahve done something wrong...  Or is two months too short time for MS to react to a very bad bug?

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 173 members 5,658 guests
Please welcome our newest community members: