cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
egallis
Level 10

BUG - Since latest release (3.18114.22), PowerApps keeps loosing SharePointIntegration datasource

Hi @TopShelf-MSFT,
Since this morning, and probably due to the latest PowerApps core update a few hours ago (updated from 3.18113.22 to 3.18114.22), the DataSource property of the SharePointIntegration control in SharePoint customized forms keeps loosing its content.

Here is a video of what's happening:

sharepointintegration.gif

As you can see, even though I refresh the datasource, the SharePointIntegration control keeps loosing the datasource.

This means that I'm stuck (and possibly many other people) and I can't modify my customized forms anymore... This is a real problem that would need a very quick fix...

Thanks for you quick reply,

Emmanuel.

1 ACCEPTED SOLUTION

Accepted Solutions
Microsoft Employee

Re: BUG - Since latest release (3.18114.22), PowerApps keeps loosing SharePointIntegration datasourc

Hello Emmanuel,

thanks again for reporting this issue. I'm hoping the workaround has worked for you so far. As an update from our end we have identified a fix and will be rolling it out soon.

 

Thanks,

Kunal.

View solution in original post

8 REPLIES 8
Flow Staff Audrie-MSFT
Flow Staff

Re: BUG - Since latest release (3.18114.22), PowerApps keeps loosing SharePointIntegration datasourc

I have created a support ticket in your behalf regarding this (reference #95862837). Support will reach out to you shortly. Is it possible to reply here to this post with your session id please?

 

How to get these on SharePoint:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/get-sessionid

 

Thank you for your patience,

Audrie

egallis
Level 10

Re: BUG - Since latest release (3.18114.22), PowerApps keeps loosing SharePointIntegration datasourc

Hi @Audrie-MSFT,

Here is my session ID:

ID de session : 5c2a5a29-2302-4d2f-97db-33fd63252491
PowerApps 3.18114.22

Cheers,

Emmanuel

Microsoft Employee

Re: BUG - Since latest release (3.18114.22), PowerApps keeps loosing SharePointIntegration datasourc

Hello Emmanuel,

thank you for reporting this issue, we're actively looking into this.

While we are addressing the issue it appears that there might be a way for you to get unblocked on modifying your application. Can you please try the following steps and see if they work for you:

  • Edit the application (as usual) by clicking on "Customize Forms" from your SharepointList "Salariés".
  • Once you are in the PowerApps Studio App Edit experience, make the necessary changes to your app.
  • When you're done with the necessary changes to the app, follow the steps from below in succession:
    1. Click on the SharePointIntegration control in the left pane.
    2. This should show up the DataSource field in the formula bar on the top. If the DataSource value shows up as empty "" fix it to say "Salariés" (or the desired datasource name).
    3. Now click on "Back to SharePoint" (without clicking anywhere else) and hit "Save and Publish".
  • Once you're redirected to the SharePoint site, refresh the site and see if your necessary changes have made it to the app.

 

Please let us know if these steps unblock you. We will keep you updated on the fix.

Thanks,

Kunal.

 

egallis
Level 10

Re: BUG - Since latest release (3.18114.22), PowerApps keeps loosing SharePointIntegration datasourc

Hello @Kunal,

Yes your workaround solution works. For your information, instead of clicking the "Back to SharePoint" link (and quit the PowerApps editor), using the "Save" and then "Publish" actions in the "File" menu works as well.

But I have also notice this (IMPORTANT):

  • the first time you arrive into the PoweApps editor right after clicking on the "Customize forms" option in the PowerApps menu of my list, if you don't go on the SharePointIntegration control it doesn't loose it DataSource property value
  • but if you click just once on the SharePointIntegration control, then it'll loose its DataSource content as soon as it looses it focus (clicking outside the form or clicking on a datacard) -> and this is true even if you save and publish the form after re-entering the datasource for the SharePointIntegration control

This means that, since we very often need to work on the SharePointIntegration control, the only way to continue working on the form in the PowerApps editor is that one MUST leave the PowerApps editor after saving and publishing and come back to it again using the "Customize forms" option in the PowerApps menu of the list.

So your workaround using the "Back to SharePoint" link seems the best option for now.

But of course, it is a great loss of time for us until you provide us with a fix on this issue.

Anyway, thank you for your help with this.

Cheers,

Emmanuel

Microsoft Employee

Re: BUG - Since latest release (3.18114.22), PowerApps keeps loosing SharePointIntegration datasourc

Hello Emmanuel,

glad to know that the workaround has unblocked you for now. We are actively investigating this to get a fix ready at our end and will update you once we have it ready.

 

Thanks,

Kunal.

Microsoft Employee

Re: BUG - Since latest release (3.18114.22), PowerApps keeps loosing SharePointIntegration datasourc

Hello Emmanuel,

thanks again for reporting this issue. I'm hoping the workaround has worked for you so far. As an update from our end we have identified a fix and will be rolling it out soon.

 

Thanks,

Kunal.

View solution in original post

egallis
Level 10

Re: BUG - Since latest release (3.18114.22), PowerApps keeps loosing SharePointIntegration datasourc

Hi @Kunal,

The bug is now fixed. Thanks for your swiftness in correcting this issue.

Cheers,

Emmanuel

Highlighted
posterme
Level: Powered On

Re: BUG - Since latest release (3.18114.22), PowerApps keeps loosing SharePointIntegration datasourc

Hi Guys,

 

for me, I'm not able to get it up and running 😞 .

is it normal, that SharepointIntegration is always marked with an "Questionmark"? :

Snipaste_2019-01-17_14-48-36.png

 

I have modified the OnNew/OnEdit/OnView, but Sharepoint always uses the "first" Screen in the left pane...

 

Thanks in advance,

Philip

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 366 members 6,612 guests
Please welcome our newest community members: