cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
egallis
Level 10

Bug ? Components FILL property not visible anymore in use mode

Hi PowerApps Team,

Seems like recently the Fill property for components disappeared from the list of properties when using a component on a screen...

When editing the component:

Image 9.png

When using the component in a screen:

Image 8.png

I'm almost certain the property was visible just a few days ago... Anyone else noticed this ?

Emmanuel

1 ACCEPTED SOLUTION

Accepted Solutions
PowerApps Staff yfw
PowerApps Staff

Re: Bug ? Components FILL property not visible anymore in use mode

We are coming up with a fix. It shouldn't disappear. Appology for inconvience. Thanks folks on the discussion plus work-around. 

View solution in original post

4 REPLIES 4
PowerApps Staff CarlosFigueira
PowerApps Staff

Re: Bug ? Components FILL property not visible anymore in use mode

Thank you for reporting this issue. I've notified the teams that own this feature and they're investigating it.

Super User
Super User

Re: Bug ? Components FILL property not visible anymore in use mode

I checked this morning with both an exisiting app that I am editing and a brand new app, created just for the purpose of testing this. 

 

On both:

Fill DOES still exist as a property on the component. 

Fill DOES NOT exist as a property on the inserted component.

 

This seems to be logically correct to me.  I would expect to set the fill property for the component, rather than the instantiated component.  With that being the case, you can use a custom property to still change the fill color.

 

  • Let's say we have a Component named, Header.
  • Define a custom property called, for example, MyColor which has a type of Color. 
  • Then, in the Fill property of the component's object I want to parameterize the color, use Header.MyColor as the value for the Fill property.  (Remember that format is  <component name>.<custom property name>
  • Set the value you want for MyColor in both the master instance (as a default) and the instantiated instances, allowing you to pass a unique color value to the component even though  fill does not appear as an option on the instantiated component.

    @Mr-Dang-MSFT video introduction on components demonstrates this at right about 3 minutes in the following:  https://powerapps.microsoft.com/en-us/blog/components-available-in-preview/
Community Support Team
Community Support Team

Re: Bug ? Components FILL property not visible anymore in use mode

Hi @egallis ,

Based on the issue that you mentioned, I have made a test, and the issue is confirmed on my side.

 

Currently, within PowerApps, the Fill property has been removed from the Copy Instance of a Component control.

If you want to chage the Fill property of the Copy Instance of your imported Component, please consider change the Fill property of the Master Instance of the imported Compent, then the changes would be applied to the Copy Instance of the conponent.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
PowerApps Staff yfw
PowerApps Staff

Re: Bug ? Components FILL property not visible anymore in use mode

We are coming up with a fix. It shouldn't disappear. Appology for inconvience. Thanks folks on the discussion plus work-around. 

View solution in original post

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 135 members 5,399 guests
Please welcome our newest community members: