cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Super User
Super User

Bug? Filter on SharePoint choice filed not working correctly

I have a SharePoint list (migrated from SP2013 to SP Online via ShareGate in case that is relevant) with a Yes/No column named Active Contact.

There are 900 contacts marked as Active (Active Contact = Yes) and 3 inactive (Active Contact = No). When attempting to filter: Filter(contacts,ActiveContact = false) I get the 3 contacts as expected. If I filter on Filter(contacts,ActiveContact = true) I get the same 3 contacts ?!?!?

The data filters correctly directly in the SharePoint list view and in Access (when linking to the list).

I'm going to try deleting and recreating the Active Contact list to see if that makes any difference. Filtering on other fields in the list appears to be OK.

 

Filter Bug.pngFiltering Bug

 

1 ACCEPTED SOLUTION

Accepted Solutions
Super User
Super User

Re: Bug? Filter on SharePoint choice filed not working correctly

Hi Kris @v-xida-msft

 

Well, I have a workaround, so I'll go ahead and mark as resolved, but the underlying long-standing bug in PowerApps still exists. Any news on work towards a resolution?

Thanks

Paul

View solution in original post

3 REPLIES 3
Super User
Super User

Re: Bug? Filter on SharePoint choice filed not working correctly

OK, seems this is a long standing issue - there is a thread on it here: 

https://powerusers.microsoft.com/t5/General-Discussion/Filter-will-not-filtering-properly-with-Share...

I have worked around the issue by using 1 and 0 instead of true and false (note don't use =0 and <>0, that seems to be broken as well). Beacuse the data types don't match, the filter is non-delegable but fortunately I am filtering by two predicates and have done this as a filter within a filter, with the inner most filter being delegable so as to limit the number of results that must be sent to PowerApps for processing:

Filter(Filter(Contacts,CalculatedCompanyID = DataTableCompany.Selected.ID),ActiveContact = 1)

 

Community Support Team
Community Support Team

Re: Bug? Filter on SharePoint choice filed not working correctly

Hi @PaulD1,

Have you solved your problem?

If you have solved your problem, please go ahead and click “Accept as Solution” so that this thread will be marked for other users to easily identify.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Super User
Super User

Re: Bug? Filter on SharePoint choice filed not working correctly

Hi Kris @v-xida-msft

 

Well, I have a workaround, so I'll go ahead and mark as resolved, but the underlying long-standing bug in PowerApps still exists. Any news on work towards a resolution?

Thanks

Paul

View solution in original post

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,122)