cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
T_R_O_N
Level: Powered On

Bug Report: Powerapps not enforcing required fields.

I've noticed something annoying with my edit forms. Even though I have a data card's requred property set to true, the form still allows the submition of blank information in that card's upload property, and then blank fields end up in my data source.

 

This is happenig on several different edit forms, and when using both exel tables and share point lists as data sources.

1 ACCEPTED SOLUTION

Accepted Solutions
PowerApps Staff FelixCuadrilla
PowerApps Staff

Re: Bug Report: Powerapps not enforcing required fields.

Hi, thank you for reaching to us.

 

After a few tries, we were finally able to reproduce this issue. We are currently working on a fix for this and will be available on a future release.

View solution in original post

24 REPLIES 24
PowerApps Staff FelixCuadrilla
PowerApps Staff

Re: Bug Report: Powerapps not enforcing required fields.

Hi, thank you for reaching to us.

 

After a few tries, we were finally able to reproduce this issue. We are currently working on a fix for this and will be available on a future release.

View solution in original post

Community Support Team
Community Support Team

Re: Bug Report: Powerapps not enforcing required fields.

Hi T_R_O_N,

 

I test this issue on my side, the Required field just works fine.


My app is based on SharePoint list, the Title field is the default required field, then I set the Required property of the Text data card to True.
When I submit data without entering an value in the Text field, I would get an error message looks like below.
And the data won’t save to the data source.

1.png

 

Could you please try again with it. If you are still getting this issue, please feel free reply.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
T_R_O_N
Level: Powered On

Re: Bug Report: Powerapps not enforcing required fields.

The issue does not appear all the time, I'm not sure what triggers it. But when the issue does pop up, I'm able to solve it by setting all required data cards to false, and then saving the app and reopening it. Once the app is reopened I can set the required properties back to true again, and then they work as expected.

 

Interestingly, simply setting the required properties to false, saving the app, and then setting them to true again does not fix the problem, then app needs to be reopened.

Community Support Team
Community Support Team

Re: Bug Report: Powerapps not enforcing required fields.

Hi T_R_O_N,

 

Thanks for sharing the workaround.


I tried this issue on my side again but I was still not able to reproduce this issue on my side.

 

As @FelixCuadrilla has reproduced this issue, hope it could be fixed and be available in the future.


Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
JayDee
Level: Powered On

Re: Bug Report: Powerapps not enforcing required fields.

Hi @T_R_O_N,

 

I'm not sure if this is the same issue you've been experiencing, but when I had fields that have a required:True property, it is possible to get around this validation by doing the following:

 

  • Entering any data into the input field
  • backspacing so that there is no data in the input field

 

This then allows you to bypass mandatory entry fields. I've tested this on multiple forms and it seems to be persistent.

T_R_O_N
Level: Powered On

Re: Bug Report: Powerapps not enforcing required fields.

No my issue isn't quite the same. I can actualy leave the update property of the data card blank, and SubmitForm still submits even though the requred property of that card is set to true. 

RaFun
Level: Power Up

Re: Bug Report: Powerapps not enforcing required fields.

Are you using any variable in the datacard default property? 

I can reproduce when there is a variable there, not the "ThisItem.Field". If you clean the text and don't update the variable (UpdateContext) the issue of saving blank data happens for me. 

Anonymous
Not applicable

Re: Bug Report: Powerapps not enforcing required fields.

I am having the same issue, I have 2 apps that both have required fields. When previewing the app i get the required fields message which is good, however when running the app fully (not in preview mode), there is no error message and the submission goes through even when the required fields are not filled out.  Both are connected to SharePoint lists and Flow. I have updated the fields (switched to false, saved, published, then switched to true, saved and published and still doesnt fix the issue. any one else have the same issue?

Lord_Alexander
Level: Powered On

Re: Bug Report: Powerapps not enforcing required fields.

Was this ever fixed?

 

I have Excel page connected to fields, and required setting to true does nothing, I can still submit blank information.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 233 members 6,667 guests
Please welcome our newest community members: