cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
imaliasad
Level: Powered On

Checkbox default value perform in a weird way

Greetings All,

 

I have a gallery list of checkboxes where on its default event I'm checking whether or not the checkbox value should be marked as tick or not. The app works successfully on the web, and it displays the tick mark on those checkboxes which have the data. However, when the same app is run on the mobile devices it doesn't mark the checkbox value to true. I've tested the app on a few devices, on one mobile device the checkbox value displayed tick mark and on the rest of the mobile devices it doesn't display the tick mark.

 

I'm not sure is it the issue with the power app, or with mobile OS or with my code.

Can anyone help me figure out this problem?

 

Capture.PNG

Following is the image of that one exceptional device where the checkbox value was display as true. and with another device where the checkbox value displays the true mark. Thank you

 

WhatsApp Image 2019-07-15 at 3.04.55 PM.jpegWhatsApp Image 2019-07-15 at 3.04.56 PM.jpegWhatsApp Image 2019-07-15 at 3.04.57 PM.jpeg

1 ACCEPTED SOLUTION

Accepted Solutions
imaliasad
Level: Powered On

Re: Checkbox default value perform in a weird way

I found the solution, the problem was with the date format. In some devices, date was stored in July 15, 2019 format while on some the date was being stored in 7/15/2019.  So, when I was filtering the data of today by string comparison it doesn't make the checkbox mark tick. 

View solution in original post

2 REPLIES 2
Highlighted
Super User
Super User

Re: Checkbox default value perform in a weird way

@imaliasad 

I would be suspect of DailyCheck.

As a test, I would put a label on the screen somewhere with the following formula:

   CountRows(DailyCheck)

 

Then try this on the different devices and see if the label count is the same on all of them or if they are different.

 

I hope this is helpful and leads to a solution.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.
imaliasad
Level: Powered On

Re: Checkbox default value perform in a weird way

I found the solution, the problem was with the date format. In some devices, date was stored in July 15, 2019 format while on some the date was being stored in 7/15/2019.  So, when I was filtering the data of today by string comparison it doesn't make the checkbox mark tick. 

View solution in original post

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (4,413)