cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
TurboTape
Level: Powered On

Re: Choosing from galleri do not work when testing in editor

Did you do anything, or just wait? And do you still have version 3.19052.19?
I still get the same result. App starts, choosing a menu item, app restart and no response from the gallery item I click on. 

 

I'm tried to edit, save and publish a new version now to see if it helps, but same...  

Ollek
Level: Powered On

Re: Choosing from galleri do not work when testing in editor

@TurboTape 

Hi I did do some test like the following 

 

1. I created a new app

2. I insert (new ones) the two galleries that I have on my start screen 

3. Then I copied the screens from my faulty app, but only one that show column or was not connected to my galleris. 

3 then i tryed to do the same with update screen, but then the error came back to the galleries. So insteed I copyed all from the screen except the update form. 

4 I the remaded the update form without coping anyting from the fault app form.   

5. I also took way all code that contened "Concurrent", I have a mistake about using that. 

And after that the new app work as the old one.  Though when I saw that a version 3.19052.18 was released i went back to the old to test it again, now it worked. 

So you kan say that I waited .   For me it look liked there was some error in the connection between the galleri and the newform.   

Kind regards 

Olle 

 

 

 

 

 

TurboTape
Level: Powered On

Re: Choosing from galleri do not work when testing in editor

@Ollek 

 

Good to hear it works for you, and thanks for sharing your experience. 

I had power apps version 3.19052.18 on Friday, and everything was OK. Today its version 3.19052.19 and all my apps get the gallery problem if I edit them in the new version. They will run fine on .16, .17 and .18. My problem is I did a small bugfix on my biggest app this morning, and now it's stuck on .19 . I tried to roll back to .18 and .17, but it didn't help. 😞

 

It seems like a gallery problem as I have multiple functions failing, from edit form to just showing details about an item in a text box. All galleries within the app are failing in all the apps I have. 

 

I really hope I don't have to copy + paste to a new one, as I have a very large business system app for my company. 

 

For me, it seems like a .19 issue.

RuslanG
Level: Powered On

Re: Choosing from galleri do not work when testing in editor

getting the similar issues with gallery control in our apps under 3.19052.19. Previous versions worked ok.
Hope it will be resolved soon.

Andy_
Level: Powered On

Re: Choosing from galleri do not work when testing in editor

Hi All,

I am also experiencing this on a number of my apps for a client, a few of which are in production.
There is something very fishy going on.
To explain it simply.
On a page you have 2 galleries and a button.
Gallery 1 (Gallery_SiteVisits) has a listing of orders. Its 'Items' property is

SortByColumns(Filter(Col_Service_Bookings,varClaimUserName = Agent.Claims && Completed = "No"),"Modified",Ascending,"Client_Site_Name",Ascending)


Gallery 2 has a listing of client details where the the 'Items' property is

Filter(ClientsCollection,Client_Name_Site = Gallery_SiteVisits.Selected.Client_Site_Name)


Now when I am in edit mode, and I click an entry on gallery 1, the 2nd gallery will display the details based on the 'Gallery.Selected' method
It doesnt.
BUT, if I go to the code and delete a few characters from the 'Gallery_SiteVisits.Selected.Client_Site_Name' and then allow the autocomplete to suggest the column from the selected operation suddenly it works.
BUT... only once. You can click the Gallery 1 items as many times as you want with no effect.
Odd.
Then the final 3rd item on the screen is a label which I am using as a button. On the label , on the 'DisplayMode' function we have this.

If(CountRows(Gallery_ServiceVisitDetails.AllItems)>0,DisplayMode.Edit,DisplayMode.Disabled) 

Very basic, If the number of rows in that gallery are greater than zero, then display it as editable/clickable. If not, make it disabled.
This also doesnt work. I can edit the formula, by editing the digit and the formula does evaluate but doesn't action anything?
If you use the formula view in the code text area, you can see the gallery has 2 items in it. But the control wont unlock to be in edit mode.
Capture.PNG

Worth mentioning, I have tried multiple browsers, tried multiple computers and the same issue.
I rolled back a number of versions, no change.
I created a brand new app, and copied and pasted each screen and code in, Same issue.

Then I created a new app, and used a very basic setup
2 galleries, each using the sample data 'CustomGallerySample'
The 2nd gallery was filtered by the selected item from gallery 1.
This worked intermittently first did then did not?

Weirdly enough, all the apps work when you run it in 'play' mode but they dont work in edit mode?
I am currently on version 3.19052.19 and roll backs to odler versions have not helped.

Please, any assistance is highly appreciated.
Thanks,
Andrew

 

PowerApps Staff _Corey_
PowerApps Staff

Re: Choosing from galleri do not work when testing in editor

@KKhafaji @Ollek @TurboTape @RuslanG @Andy_ We have identified the issue and we are actively working on a hotfix.  We will keep the thread posted as we know more.  Sorry for any inconvenience.

Mike4
Level: Powered On

Re: Choosing from galleri do not work when testing in editor

Hi Corey,

This is impacting a PowerApp application that I have in production. I have had to implement contingency plans to work around this.

Updating the forum of the status of where this is at is very important ................

 

 

 

 

PowerApps Staff _Corey_
PowerApps Staff

Re: Choosing from galleri do not work when testing in editor

@Mike4 Your concern is understood. 

 

Update: A hotfix has been validated and is approved for deployment. Once deployed, you will need to edit your app(s) in Studio and re-publish. I will update this thread once hotfix deployment is complete.

TurboTape
Level: Powered On

Re: Choosing from galleri do not work when testing in editor

@_Corey_ 

 

Thanks for keeping us updated.
Do you have a time estimate for the deployment? Its a new day at my location and the users are asking. 

PowerApps Staff _Corey_
PowerApps Staff

Re: Choosing from galleri do not work when testing in editor

Update: We are still working to deploy the hotfix. We encountered a technical issue which prevented us from deploying sooner. I will update this thread again once hotfix deployment is complete.

 

@TurboTape We expect the deployment to complete shortly.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (4,937)