cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
brinda_rajani
Level: Powered On

Count function does not work when PowerApp is accessed via applink

Hi ,
On the main screen of my app , I have a gallery which is connected to a Sharepoint list , in the same screen I have added another counter which counts the number of items in the gallery
This counter displays the right value when I access the app through my phone or tablet and also when I access the app in the browser via the app link
The issues arises when I pass parameters in the link and try accessing the app
In this case , the counter displays 0
Any clue why is this happening and how can it be solved ?
1 ACCEPTED SOLUTION

Accepted Solutions
v-siky-msft
Level 10

Re: Count function does not work when PowerApp is accessed via applink

Hi @brinda_rajani ,

 

That's great. 

Hopefully, you can mark the click your post on “Accept as Solution” to finish the thread and help other members find it more quickly.

 

Best regards,

Sik

View solution in original post

3 REPLIES 3
v-siky-msft
Level 10

Re: Count function does not work when PowerApp is accessed via applink

Hi @brinda_rajani ,

 

Could you share more details with your issue?

1. What is the usage of parameter?

2. What is the formulas you used to count the gallery item? CountRows(Gallery1.AllItems)?

I have made a test based on your description, but don't have the issue your mentioned.

In my test, I use the passed parameter to filter the gallery, and use countrows function to count the gallery items.

Snipaste_2019-11-07_10-06-42.pngNo parameterSnipaste_2019-11-07_10-09-19.pngwith a patameter

Also you can follow my test to check if your issue still remains.

Best regards,

Sik

If my post is helpful for you, please click on “Accept as Solution” to help other members find it more quickly.

brinda_rajani
Level: Powered On

Re: Count function does not work when PowerApp is accessed via applink

HI @v-siky-msft ,

The issue is fixed .

Actually the parameter that was being passed was breaking the link which led to the count function not displaying the correct value.

I simply renamed the parameter and the issue was fixed.

Thanks for your help 🙂

 

v-siky-msft
Level 10

Re: Count function does not work when PowerApp is accessed via applink

Hi @brinda_rajani ,

 

That's great. 

Hopefully, you can mark the click your post on “Accept as Solution” to finish the thread and help other members find it more quickly.

 

Best regards,

Sik

View solution in original post

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,304)