cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
ocantu
Level: Powered On

Custom Visual showing values in Studio (app designer) but not in the Report.

Hi,

 

I'm trying to capture data from a PowerBI report.

 

The first two related tables from the report are captured by the PowerApp perfectly.

 

But now, I've added two DAX formulas to be capture by the PowerApp. In PowerApps Studio the two formulas are shown and they look good, but not in the Report. Do you know what I'm missing?

 

In PowerApps Studio:

PowerAppStudio.png

 

In PowerBI Report:

PowerAppReport.png

1 ACCEPTED SOLUTION

Accepted Solutions
ocantu
Level: Powered On

Re: Custom Visual showing values in Studio (app designer) but not in the Report.

Hi @TopShelf-MSFT :

 

I fixed this. PowerApps was expecting a numeric value, that's why it was showing an empty field.

 

The Data type needs to be specified under PowerBI Desktop, when selecting the visual, under Modeling > Data Type:

PowerBIDesktop.png

 

Needs to match what PowerApps is expecting:

PowerBIDesktop2.png

 

View solution in original post

5 REPLIES 5
Community Support Team
Community Support Team

Re: Custom Visual showing values in Studio (app designer) but not in the Report.

Hi @ocantu ,

Could you tell me do the two DAX formulas set inside a form?

Based on your picture, I think this is an edit form.

If it is an edit form, please notice its mode.

I suggest you set the edit form's DefaultMode to FormMode.Edit.

Set the two fields' default value to the value that you want.

 

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
ocantu
Level: Powered On

Re: Custom Visual showing values in Studio (app designer) but not in the Report.

@v-yutliu-msft thanks for your response.

 

Actually yes, it is an edit form. 

Default Form mode was set to New, I've changed it to Edit, without success.

 

Default values for two fields are as follow:

DashboardGallery.Selected.'PowerBI Field1'

DashboardGallery.Selected.PowerBI_Field2

 

Again, value is shown in the PowerApps studio, not in the Report 😞

ocantu
Level: Powered On

Re: Custom Visual showing values in Studio (app designer) but not in the Report.

Hi, this is probably a BUG.

 

PowerApps is not sending the values back to the Report when using DAX fields. 

DAX fields formulas:

Field1_Selected = SELECTEDVALUE(Dim_Field1[SL Field1 (Code)])
Field2 Selected = SELECTEDVALUE(Dim_Organization[SL Field2 (Code)])

 

Are based on a selection of a Slicer.

 

Fields looking OK in the PowerApps Studio:

BugPowerApps2.png

 

DAX fields are empty in the Report:

BugPowerApps1.png

 

Administrator
Administrator

Re: Custom Visual showing values in Studio (app designer) but not in the Report.

Hi @ocantu are you still experiencing this issue? 

 

@TopShelf-MSFT 

ocantu
Level: Powered On

Re: Custom Visual showing values in Studio (app designer) but not in the Report.

Hi @TopShelf-MSFT :

 

I fixed this. PowerApps was expecting a numeric value, that's why it was showing an empty field.

 

The Data type needs to be specified under PowerBI Desktop, when selecting the visual, under Modeling > Data Type:

PowerBIDesktop.png

 

Needs to match what PowerApps is expecting:

PowerBIDesktop2.png

 

View solution in original post

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 271 members 5,295 guests
Please welcome our newest community members: