cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
stefanyobando
Level: Powered On

Data entered is not displayed when I open an item in SP Online, power apps

Hi,

How can I do so that when I select an item the information already entered in the form is displayed?

I have an application, all forms are in Edit mode, when I send the information is saved correctly in the list, I have a workflow that is executed every time a new item is entered, the flow sends a message to a member of the company to enter of the Item and modify some fields, but when the link arrives, the form is as if it were new, it does not load the information already entered. Any suggestions of what it can be? I am new to using power apps. Thanks for the help.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Super User
Super User

Re: Data entered is not displayed when I open an item in SP Online, power apps

Are you using a PowerApps custom form in the SharePoint list? If so, then based on the screenshot something was changed on the PowerApps app because the property for the Form Item is not correct. 

 

Normally a Form > Item property looks something like this:

If(IsBlank(SharePointIntegration.Selected) || IsEmpty(SharePointIntegration.Selected),First('SPListName'),SharePointIntegration.Selected)

There is also a SharePointIntegration control that makes sure the correct Form Mode (New, Edit or View) gets set in the form. From your description it sounds like the Form is always opening in Form Mode New.



--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

View solution in original post

mdevaney
Level 8

Re: Data entered is not displayed when I open an item in SP Online, power apps

@stefanyobando 

In the email link notice the value for ID is 13.  This is likely the ID number of the record in your Sharepoint List. 

 

img1.png

 

You need to use this ID to tell PowerApps what record to open in your form.  In the OnStart property of your app input the following code

 

Set(PassedID,Param(ID))

 

And then change the Items property of your form to the following

 

First(Filter('Employee Setup/Change Request',ID=PassedID))

 

I believe this will make the correct data appear.  The doucmentation on the PARAM function is not very good so unfortuantely I don't have additional info to share

 

---
Please click "Accept as Solution" if my response helped to solve your issue so that others may find it more quickly. If your thought the post was helpful please give it a "Thumbs Up."

View solution in original post

8 REPLIES 8
mdevaney
Level 8

Re: Data entered is not displayed when I open an item in SP Online, power apps

@stefanyobando 

Take a look at the Default property of one of the DataCards.  Does it look something like this?  The default value defines what is displayed in the control.

 

ThisItem.FieldName

 

I feel this is the best place to start.  Let me know what code yours has.

 

---
Please click "Accept as Solution" if my response helped to solve your issue so that others may find it more quickly. If your thought the post was helpful please give it a "Thumbs Up."

stefanyobando
Level: Powered On

Re: Data entered is not displayed when I open an item in SP Online, power apps

Thank you for responding, yes, the data card of each item in the form is like this

 

 

mdevaney
Level 8

Re: Data entered is not displayed when I open an item in SP Online, power apps

@stefanyobando 

Three more questions:

 

#1 Can you provide a sample link from your email?  I want to see whether the form ID number is being sent as a parameter?

#2 What is the Item property of your form set to?  Please share the code

#3 Are you using the PARAM function to capture the form ID number in your email?

 

stefanyobando
Level: Powered On

Re: Data entered is not displayed when I open an item in SP Online, power apps

I attached the images. In the workflow I call the Item in this way and so the link in the mail is shown.

The Item property of the form calls the datasource.

I am not using the PARAM function, could you explain how to do it?

Super User
Super User

Re: Data entered is not displayed when I open an item in SP Online, power apps

Are you using a PowerApps custom form in the SharePoint list? If so, then based on the screenshot something was changed on the PowerApps app because the property for the Form Item is not correct. 

 

Normally a Form > Item property looks something like this:

If(IsBlank(SharePointIntegration.Selected) || IsEmpty(SharePointIntegration.Selected),First('SPListName'),SharePointIntegration.Selected)

There is also a SharePointIntegration control that makes sure the correct Form Mode (New, Edit or View) gets set in the form. From your description it sounds like the Form is always opening in Form Mode New.



--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

View solution in original post

mdevaney
Level 8

Re: Data entered is not displayed when I open an item in SP Online, power apps

@stefanyobando 

In the email link notice the value for ID is 13.  This is likely the ID number of the record in your Sharepoint List. 

 

img1.png

 

You need to use this ID to tell PowerApps what record to open in your form.  In the OnStart property of your app input the following code

 

Set(PassedID,Param(ID))

 

And then change the Items property of your form to the following

 

First(Filter('Employee Setup/Change Request',ID=PassedID))

 

I believe this will make the correct data appear.  The doucmentation on the PARAM function is not very good so unfortuantely I don't have additional info to share

 

---
Please click "Accept as Solution" if my response helped to solve your issue so that others may find it more quickly. If your thought the post was helpful please give it a "Thumbs Up."

View solution in original post

stefanyobando
Level: Powered On

Re: Data entered is not displayed when I open an item in SP Online, power apps

Thank you! the application works successfully now! Enter this function in the forms and now it works.

stefanyobando
Level: Powered On

Re: Data entered is not displayed when I open an item in SP Online, power apps

I have another question, Why the patch does not save me the information in edit mode, it only works for `` new '' mode.and I need the data to be saved in edit mode. Or at least the Submit button changes the forms to edit mode so that when the person enters the Item the information is loaded.I appreciate the help. patch.PNG

 

 

 

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 150 members 5,150 guests
Please welcome our newest community members: