cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
C0ntr0lledCha0s
Level: Powered On

Data from SharePoint lists not loading.

Hi,

 

New to the Powerapps community, recently delved into building my first app. I had an app that was perfectly working until yesterday (14/06/2018). All of a sudden all my app stopped pulling data and writing back. Not sure what caused the issue. Is anyone else having this issue?

1 ACCEPTED SOLUTION

Accepted Solutions
C0ntr0lledCha0s
Level: Powered On

Re: Data from SharePoint lists not loading.

*Update*

 

I haven't made any further changes to my app but it started working again so assume Microsoft fixed the problem from there end.

 

Thanks everyone for your help!

View solution in original post

12 REPLIES 12
v-sttaub
Level: Powered On

Re: Data from SharePoint lists not loading.

Are you using Sharepoint as the data source?

I'm having the exact same problem, unable to load my SP back into my poweapps. Something wrong with the SP conectors?

 

For me, I first starting noticing this on 6/12/18 about 3:30 pm.

C0ntr0lledCha0s
Level: Powered On

Re: Data from SharePoint lists not loading.

Yeah using 3 sharepoint lists and a office365 userbase. When I try to manually refresh the sharepoint list while in powerapps edit mode I get an error "unable to refresh"

Highlighted
v-sttaub
Level: Powered On

Re: Data from SharePoint lists not loading.


@C0ntr0lledCha0s wrote:

Yeah using 3 sharepoint lists and a office365 userbase. When I try to manually refresh the sharepoint list while in powerapps edit mode I get an error "unable to refresh"



that is almost exactly the problem I'm getting, And when i try to refresh the data it says "Try again"

 

I think it's a Sharepoint or Powerapps bug. I tried reporting it but for some reason I had trouble logging in. You might want to report it as a bug since I'm also getting the same problem.

Community Support Team
Community Support Team

Re: Data from SharePoint lists not loading.

Hi @C0ntr0lledCha0s,

 

I just checked my apps with Office365 users and SharePoint connector, all are connected and working perfectly. Would you please check the connection status on the connection list in PowerApps home site? 

Capture.PNG

 

If the status is not Connected, please fix the connection there and then test again. If this still does not solve the issue, please try to delete old one in the app and readd the connection to have a test.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
C0ntr0lledCha0s
Level: Powered On

Re: Data from SharePoint lists not loading.

Hi @v-monli-msft,

 

My connections are showing fine.

 

 

2018-06-15_14h42_37.png

 

I tried deleting the connection, re-connecting and deleting > reconnecting in the edit function of the appp but with the same error message.

rmmcgr
Level 8

Re: Data from SharePoint lists not loading.

I think this is more than just SharePoint, I am getting something similar with trying to refresh a connection for a Azure SQL database.

When I click the elipsis next to a table, the Data Sources list, and choose Refresh it displays a little "Try Again".

tryagain.png

DeanCavanagh
Level: Power Up

Re: Data from SharePoint lists not loading.

Exact same issue here. This has occurred between PowerApps version 3.18061.12 and 3.18062.23.

 

Since 3.18062.23 - my apps can't be touched as they will break.

 

For clarity, my apps still work so long as I don't change anything. My functions and filter all work, however if I look at them, its completely wrong. EG: If I look at the 'Items' field in one of my gallery which has a series of filters, if statements, etc, all of that is missing and its just a single line of code from a different version. Yet the function still works fine... so long as I don't modify it.

v-sttaub
Level: Powered On

Re: Data from SharePoint lists not loading.

everything listed here is happening to my appa as well.  There is no undo if we disconnect connections and reconnect.

 

 

However I made a duplicate screen and added a connection. It worked only while connecting for the first time, then stopped like all my connections in my app.

v-sttaub
Level: Powered On

Re: Data from SharePoint lists not loading.

I think this is an issue that needs to be considered a showstopper and dealt with.  Currently it is not possible to move forward in my app development until this is resolved, and with a number of people reporting almost the exact same thing, this is not someone or some people just not knowing how to do things.

 

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 326 members 5,434 guests
Please welcome our newest community members: