cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
HawkinsGabriel
Level: Powered On

Deleted Screens Still Showing in app

In an attempt to figure out why my app wasn't launching (https://powerusers.microsoft.com/t5/General-Discussion/No-Data-Source-Provided-No-Item-to-Display-on...), I made a copy of the app so that I could go in and delete screens in order to see where the offending error was.

 

After deleting a few screens, I saved and closed.  Upon running the test copy w/ deleted screens, the app launched perfectly, but with all screens (including the deleted ones)!  I'm grateful and excited to see my app work, but surely something has to be wrong.  The screens are still gone when I open it up to edit, so I don't know how I could make changes in the future to any of the slides I'd deleted.

 

What is going on here?

 

6 REPLIES 6
Super User
Super User

Re: Deleted Screens Still Showing in app

Your browser may have cached a copy of the App (with all the screens), try doing a forced refresh (Ctrl+F5) when it loads.




Don't forget to 'Mark as Solution' if a post answered your question and always 'Thumbs Up' the posts you like or helped you!
HawkinsGabriel
Level: Powered On

Re: Deleted Screens Still Showing in app

I tried that (also tried signing in and out a few times), but it's still showing all screens.

 

I tried making another test copy of the original app, but making no changes.  The second test copy ALSO opens and runs without any issues, while the original app still doesn't work.

Super User
Super User

Re: Deleted Screens Still Showing in app

Ouch, ok, well was worth a shot, atleast you got it working with all of the screens editable, might be worth raising as an issue via the O365 admin portal




Don't forget to 'Mark as Solution' if a post answered your question and always 'Thumbs Up' the posts you like or helped you!
HawkinsGabriel
Level: Powered On

Re: Deleted Screens Still Showing in app

Actually any changes I make to the two test copies (and even the original app) aren't reflected when I rerun either of the test apps.  After fiddling around with it, I'm able to make changes by editing the original app (which won't run), and then making a new copy of the edited original.  I guess that works, but creating a new app everytime I need to make a change just doesn't seem like a good practice.

Super User
Super User

Re: Deleted Screens Still Showing in app

I've had similar issues when running Published Apps from the PowerApps portal, but force-refreshing(Ctrl+F5) the environment page before opening the app then makes the new changes show for me, can't understand why as the links to the apps remain the same, but that seemed to work for me.

Sorry that this didn't work for you, sounds like it might be a more serious issue




Don't forget to 'Mark as Solution' if a post answered your question and always 'Thumbs Up' the posts you like or helped you!
HawkinsGabriel
Level: Powered On

Re: Deleted Screens Still Showing in app

How would I best escalate this?  This is an independent account I'm using because the app I'm working on is for my employer.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (4,791)