cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Erec
Level: Powered On

Drop down not populating in Web Player or on mobile devices

Hi

 

Wondering if anyone can help?

 

I've noticed over the past week or so that when i create new apps the drop downs are not populating in the Web Player but it works fine in the design studio. I have tried it on various devices andriod, ios and different web browsers all yeild the same results.

 

Background:

Azure SQL Server

Populating the dropdown via a collection, the collection is populated on Start of the application. I have also tried OnVisible both producing the same results.

 

I'm not doing anything different to what I have done in previous applications which work fine. The problem does not happen on every app created, thus making it hard to troubleshoot. Any pointers on what to check to  try and resolve the problem would be appreciated.

 

There are no errors occuring when running the application(s) in the web player or mobile devices, just an empty dropdown column.

 

I have also tried adding a new dropdown and publishing, on occassion the drop down works and then stops again when published again.

 

Is anyone else experiencing the same?

 

If any further information is needed, do let me know and I will post.

 

Thanks

 

 

4 REPLIES 4
tianaranjo
Level 8

Re: Drop down not populating in Web Player or on mobile devices

Sounds similar to an issue I am having. The feature was working fine last week.  I have a Combo Box that is populated from the collection based on the datasource.  One of the two dropdowns I have works fine, however, one is empty or blank.  Formula for both is essentially the same, just references different columns within the same datasource.  

Community Support Team
Community Support Team

Re: Drop down not populating in Web Player or on mobile devices

Hi @Erec,

I have made a test on my side, and don't have the issue that you mentioned.

The user @jlister has faced same issue with you, please check the fixed solution within the following thread:
https://powerusers.microsoft.com/t5/General-Discussion/Improved-app-rendering-issues/td-p/165053

 

On your side, please take a try to turn off/disable the "Delayed load" option within the Advanced settings of App settings, and then turn on "Improved app rendering (final validation)" option, check if the issue is solved.

 

Best regards,

Kris

 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Erec
Level: Powered On

Re: Drop down not populating in Web Player or on mobile devices

Hi Kris

 

Thanks for your response. I have tried both your suggestiion and the link offered. Unfortunately it has not resolved my issue.

I have created another app today based of an existing working one. After publishing the new app and testing on mobile device, the dropdowns are still failing to poulate. The issue is not limited to the dropdown, list boxes, combo boxes are also affected. 

 

Thanks

Erec
Level: Powered On

Re: Drop down not populating in Web Player or on mobile devices

All

 

Has anyone found a solution / work around? It's becoming an issue. We have applications to deliver as I am sure others do and are unable to do so with the current situation. I'm sure the issue is more widespread than the current feedback within this thread. Is anyone from Mircosoft reading this? Are you able to help?

Thanks

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,073)