cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Dropdown from another table in Form giving a Value error

Hello,

 

So I need to access a column from another table inside a form as a dropdown. (Basically, so each value is distinct)

The thing is it works perfectly - the column values display - if I'm editing the App and press the 'play' button but if I open it directly I get an error;

"The requested operation is invalid. Server Response: The column 'Value' of the table wasn't found. inner exception: The column 'Value' of the table wasn't found".

 

Any help is appreciated,

Thank you.

 

EDIT: Alternatively is there a way I can get only distinct values from a column into a dropdown? ('Distinct' doesn't work)

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Dropdown from another table in Form giving a Value error

Found a solution, hopefully just a temporary one, basically if you want a dropdown to work in a form make sure you unselect this in App settings > Advanced Settings
res.PNG 

Everything runs slower as a result but atleast it works.

View solution in original post

3 REPLIES 3
Super User
Super User

Re: Dropdown from another table in Form giving a Value error

Hi Conner,
Try replacing Value in your formula with Result and see if that works.

Re: Dropdown from another table in Form giving a Value error

Thanks for the reply, but this didn't work, I think the problem lies with the dropdown being unable to get the column value for some reason.

 

If I navigate to the form by pressing the 'Play' button inside editing the app I get :

drop2.PNG

But if I navigate to the form by just pressing the 'Play' button from the PowerApps homepage i get:

drop1.PNG

The Column values arent found, and the error shows up.

 

The 'items' value is "Distinct('[autmeasures].[Measure_Configuration]', Measure_Group_Code)" (I managed to get Distinct to work) but the error happens regardless - with or without the distinct filter.

 

Any ideas? 

Thanks for your help

Re: Dropdown from another table in Form giving a Value error

Found a solution, hopefully just a temporary one, basically if you want a dropdown to work in a form make sure you unselect this in App settings > Advanced Settings
res.PNG 

Everything runs slower as a result but atleast it works.

View solution in original post

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 328 members 5,418 guests
Please welcome our newest community members: