cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
johnwrightPOL
Level: Powered On

Dropdown value not populated first time in Edit form

Hi,

 

I have a form that is used to edit or create items in a Sharepoint list. It has 2 dropdowns that contain static lists of options, and several text input boxes and 2 date input boxes.

 

The problem I have is that when I open the PowerApp and select an existing item to edit, all the values saved in the Sharepoint list are showing in the form, except for the 2 dropdowns, which are blank.

 

If I cancel this and then select another item to edit, the dropdowns are poulated correctly. Even if I select the same item that originally had the problem, it now works fine. So it seems the first time the form goes to Edit mode, it fails to load the dropdown values (that were saved last time).

 

Please could someone advise how I can fix this? I have tried adding various things to my Edit button, such as ResetForm(InputData), but to no avail. Also, when I run the app in preview mode from the app editor in the browser, it works fine. I am using Internet Explorer.

 

Thanks, John

3 REPLIES 3
Community Support Team
Community Support Team

Re: Dropdown value not populated first time in Edit form

Hi @johnwrightPOL,

 

Have you modified the Default property of those Dropdowns, and which fields those two dropdowns work with?

I tested with the App created from Data directly, and the auto-generated Dropdowns works as expected.

Mostly the issue you mentioned should be affected by the default property, please take a look at that part.

If they are all left with Parent.Default, it should work.

 

Regards,

Michael

 

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
johnwrightPOL
Level: Powered On

Re: Dropdown value not populated first time in Edit form

Hi,

 

I have tried to set the Default property of the dropdowns to Parent.Default as you say (they were set to ThisItem.ColumnName), but I get an error and it says 'Invalid Name':

 

Format_Default.PNGInvalid Name Error

Please could you advise if I am setting it in the correct place?

 

Many Thanks, John

johnwrightPOL
Level: Powered On

Re: Dropdown value not populated first time in Edit form

Can anyone help with this please?

 

Thanks in advance, John

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 175 members 5,725 guests
Please welcome our newest community members: