cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
lrealdon
Level: Power Up

Error connectin to mysql through gateway if table contains guids

Hi,

 

I'm testing powerApps for my organization.

I was able to create a local gateway, a mysql connection and a test app using database structure.

If I use a straight table with only one integer field and a text field, I'm also able to show records inside the app.

 

The matter is that all of my tables use Guids and if I try to connect to any of them I receive an error asking to change the OldGuids parameter to True. 

Where should I set this parameter? I can't find any possibility in Mysql connection setup and in Gateway setup.

Can you help me with this issue?

Thanks in advance.

Luca

2 REPLIES 2
Community Support Team
Community Support Team

Re: Error connectin to mysql through gateway if table contains guids

Hi @lrealdon,

 

Could you please share a bit more the error message within your app?

 

Currently, I could not reproduce your issue on my side. Please check and see if the following blog would help in your scenario:

https://paultebraak.wordpress.com/2015/12/08/mysql-import-issues-with-power-bi-and-oldguids/

 

Based on the above blog, it seems to tell that the data format error would show up if you use GUIDs within your mysql table.

 

If you want to change the OldGuids parameter to True within PowerApps. I afraid that there is no way to achieve our needs in PowerApps currently.

 

If you would like this feature to be added in PowerApps, please submit an idea to PowerApps Ideas Forum:

https://powerusers.microsoft.com/t5/PowerApps-Ideas/idb-p/PowerAppsIdeas

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
lrealdon
Level: Power Up

Re: Error connectin to mysql through gateway if table contains guids

Thanks.

You're right. That's exactly the error I found.

 

Can you please tell me which version ap mysql are you using which does not create the issue?

In my case I found innoDB 5.5.35.

 

The field causing the issue is an autogenerated 36digits long CHAR, defined as Primary Key. (ex. 103645c5-0ad5-5f29-c6af-571cd336b10e).

 

Can you please confirm you tested the same environment?

Thanks.

Luca

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 186 members 4,469 guests
Please welcome our newest community members: