cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Andrew_Aitken
Level: Power Up

Error running in web.powerapps.com but not in https://au.create.powerapps.com/studio/#

Hello 

 

I get the following error when I run the app in web.powerapps.com but when I run it from the editor in au.create.powerapps.com/studio/#. 

 

The requested operation is invalid. Server Response: Term 'Client,Name,DNS-Name,PortNumber,id' is not valid in a $select or $expand expression. inner exception: Term 'Client,Name,DNS-Name,PortNumber,id' is not valid in a $select or $expand expression. clientRequestId: 2e5abd44-7188-47da-9727-5227be068322

 

Its a Datagrid that in populated from a Azure SQL table. 

 

Cheers

Andrew

1 ACCEPTED SOLUTION

Accepted Solutions
Andrew_Aitken
Level: Power Up

Re: Error running in web.powerapps.com but not in https://au.create.powerapps.com/studio/#

Turning off Advanced setting "Eplicit Column Selection" fixed it.. 

 

View solution in original post

4 REPLIES 4
Community Support Team
Community Support Team

Re: Error running in web.powerapps.com but not in https://au.create.powerapps.com/studio/#

Hi @Andrew_Aitken 

 

Do you test with one valid account?

Could you change one environment to test?

Do you have the same issue when you test with other browsers?

Do you have the same issue when you test all your Apps?

 

Best Regards.

Yumia

 

Andrew_Aitken
Level: Power Up

Re: Error running in web.powerapps.com but not in https://au.create.powerapps.com/studio/#

Hi Yumia

I am testing with the same account as I am editing the powerapp with. 

 

It I edit the app but not make any changers and run it from inside the editor it works fine. 

But it just try and run the app it does not work. 

 

Cheers.

 

Community Support Team
Community Support Team

Re: Error running in web.powerapps.com but not in https://au.create.powerapps.com/studio/#

Hi @Andrew_Aitken 

 

Is your account is expired?

Do you save and publish app after you edit?

save-publish-app

 

Best Regards.

Yumia

Andrew_Aitken
Level: Power Up

Re: Error running in web.powerapps.com but not in https://au.create.powerapps.com/studio/#

Turning off Advanced setting "Eplicit Column Selection" fixed it.. 

 

View solution in original post

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (6,180)