cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Christy_Roach
Level: Powered On

Field acting required although it's not set at required

Hi - I'm well into the creation of a form that is tied to a Sharepoint custom list.  I had the form all laid out and then realized that I had missed a question that needed to be visible.  So I added it in and set it up in the same exact way I did all of the other questions in that category.  I moved on to creating the submit button to send the entry to the sharepoint list. 

 

I'm getting the error message back that their is a required field not completed.  But it's only that one added field and when I fill that in, the submit button does what it's supposed to.  Help! Pulling my hair out and don't want to have to go way back to a previous version because I've gotten so far along.  Any help would be very much appreciated.

5 REPLIES 5
Highlighted
seadude
Level 10

Re: Field acting required although it's not set at required

Hi @Christy_Roach,

 

Did you refresh the data source after the new column was added to the Sharepoint list?

  • View/Data Sources
  • Click the 3 dots
  • Refresh

What field is showing as "Required"? Is it that pesky "Title" column from Sharepoint?

  • On your Sharepoint list, click the Title column then make it Not Required

Good luck!

AndySid
Level 8

Re: Field acting required although it's not set at required

Personally I have perfer not using forms, but lay the controls out manually, much more flexibility.

On my save button I use  ForAll and Patch. A bit more advanced but once you understand, better.

 

Here is an example for a timesheet I did...

 

ForAll(
    cboEmployee.SelectedItems.Employee,
    Patch(
        appDailyJobSheets_1,
        Defaults(appDailyJobSheets_1),
        {
            ContractNo: cboDropContractNo_2.Selected.Contract,
            CategoryID: cboCategory_2.Selected.Result,
            Added: Today(),
            Lunch: chkLunch.Value,
            Hours_x0020_Work: HoursWorked.Text,
            Entered_x0020_By: User().FullName,
            tID: Value(tID_input.Text),
            Item_x0020_Description: cboItemDescription_2.Selected.Result,
            DateText: Text(
                DateValue11_2.SelectedDate,
                "[$-en-US]dd/mm/yy"
            ),
            Start: HourValue11_2.Selected.Value & ":" & MinuteValue11_2.Selected.Value,
            End: HourValue12_2.Selected.Value & ":" & MinuteValue12_2.Selected.Value,
            Start_x0020_Time: DateValue11_2.SelectedDate + Time(
                Value(HourValue11_2.Selected.Value),
                Value(MinuteValue11_2.Selected.Value),
                0
            ),
            Employee: Employee
        }
    )

Community Support Team
Community Support Team

Re: Field acting required although it's not set at required

Hi @Christy_Roach,

Have you set the Required property of the corresponding Data card within your Edit form to true?

Is the added field a Required/Mandatory field in your SP list?

Please check if you have set the Required property of the corresponding Data card  relaetd to the added field within your Edit form to true, if yes, please set it to false.

If the added field is not a Required/Mandatory field in your SP list, I agree with @AndySid's thought almost, you could consider submit your form data into your SP list using Patch function instead of SubmitForm function.

I have made a test on my side, please take a try with the following workaround:

Patch(
         'YourSPList',
          Defaults('YourSPList'),
          {
             Column1: DataCardValue1.Text,
             Column2: DataCardValue2.Text,
             Column3: DataCardValue3.Text,
             ....
          }
)

More details about Patch function, please check the following article:

Patch function

 

Also please consider take a try to remove the custom form from your SP list, and then re-create a new one, then check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Christy_Roach
Level: Powered On

Re: Field acting required although it's not set at required

Thank you everyone! I got this figured out.  It actually another field all together causing the issue.  

Community Support Team
Community Support Team

Re: Field acting required although it's not set at required

Hi @Christy_Roach

Have you solved your problem?

If you have solved your problem, please go ahead to click "Accept as Solution" to identify this thread has been solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 135 members 4,765 guests
Please welcome our newest community members: