cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Ryan_LaCroix
Level: Powered On

Filter Formula Not working for all for all categories in a gallery

Hi,

 

I have recently created an app that allows the user to select a certain division followed by selecting a specific category for the division that then leads the user to a list of sub-categories (with a link) that is correlated to that specific division and category. The formula I used for this process was: Filter(Table3_5, 'Category ID' = CategoryGallery_1.Selected.'Category ID', Division = DivisionGallery.Selected.Division). It was successful for all the divisions except for two of them; the subcategories list does not show up for these two divisions. Instead it leads me to a blank vertical gallery. I have tried exporting the data again into the app and nothing seems to be working. How do I go about resolving this issue? I have attached pictures below of my data and what my app should look like versus what is occuring when a user selected on the two unresponsive divisions.

 

3 REPLIES 3
Ryan_LaCroix
Level: Powered On

Re: Filter Formula Not working for all for all categories in a gallery

 
Community Support Team
Community Support Team

Re: Filter Formula Not working for all for all categories in a gallery

Hi @Ryan_LaCroix ,

That's a little strange...

Are you sure the two situation filtered items not empty?

Do you have delegation warning?

Are the three tables' record's number larger than 2000?

 

Best regards,

Community Support Team _ Phoebe Liu

 

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Ryan_LaCroix
Level: Powered On

Re: Filter Formula Not working for all for all categories in a gallery

Hi @v-yutliu-msft ,

 

No the two situation filtered items are not empty and I do not have delegation warning nor is my table larger than 2000. It is a strange situation, I have attached another picture with my data table that shows the records for the two missing items (FHP and FKC). I even tried moving around the data in the excel file and switching the ID number's of the two items but nothing seems to be working. Do have any other suggestions?

 

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,305)