cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
cmv
Level: Powered On

Filter stopped working, Not a valid connector Error response.

Problem: Yesterday a gallery stopped loading on two of my apps, they have been running fine with the code below  

Gallery items= Filter('[dbo].[NewTblAppTrips]', cmvLocationid=Dropdown5.Selected.LocationID&&'Trip Date' <Now()) 

Testing: I built a new app for testing, created a gallery and added (same) Azure SQL Cloud as my data source.

Gallery items= '[dbo].[NewTblAppTrips]' 

Gallery loaded no issues.
Changed to

Gallery items=  Filter('[dbo].[NewTblAppTrips]','Trip Date'>Now())

I got the following error. “An error occurred on the server. Server Response: Not a valid connector Error response.”

I have multiple DATE columns all gave same error when testing.
Filter does work on nondate fields.
Turned on/off Experimental Performance improvements, no help.
Also refreshed data source within PowerApps.
Limited Rows to 100
Conditions:
This is happening at multiple locations,  platforms and Apps.
 I saw nothing odd within the Azure portal.
Under Connections Azure SQL Server Status is “Connected”
Trip Date Data Type datetime2(0)
Table has 300 Rows
Ideas:
Did Microsoft change something?
Is my Filter missing something?
Any ideas or comments are appreciated.




6 REPLIES 6
Rebeccak
Level: Powered On

Re: Filter stopped working, Not a valid connector Error response.

I am experiencing the same issues.  I have narrowed it down to the <, >, >=, and <= symbols. If you test with = or <> the filters work.  But none of the others. 

cmv
Level: Powered On

Re: Filter stopped working, Not a valid connector Error response.

I got the sasme results as you = and <> filters correctly.

Rebeccak
Level: Powered On

Re: Filter stopped working, Not a valid connector Error response.

There was a new release 3.19074.24. I am wondering if something changed. All of my filters worked correctly last night, but today nothing works. I collect all of my data based on dates for my app.  This is a huge problem that this isn't working. 

cmv
Level: Powered On

Re: Filter stopped working, Not a valid connector Error response.

Update, filter works on Sharepoint list but you get a Delegation warning.

Filter(tblAppTrips,'Trip Date'<Now())

Can some else from the community support team confirm the same results on Azure and Sharepoint.

Highlighted
Community Support Team
Community Support Team

Re: Filter stopped working, Not a valid connector Error response.

Hi @cmv ,

Is your data larger than 2000?

Deleagtion is PowerApps itself limit. PowerApps could only deal with 2000 records locally. If your data is large, you should use delegable funtions. Or else your result may not be right.

If your data is larger than 2000, you should modify your formula and use delegable funtions:

https://docs.microsoft.com/en-us/connectors/sharepointonline/

If your data is smaller than 2000, the delegation warning will not effect your app performance.

Just do not remember change the non-delegable limit to 2000.delegation.jpg

 

Best regards,

Community Support Team _ Phoebe Liu

 

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Rackabajsarn
Level: Powered On

Re: Filter stopped working, Not a valid connector Error response.

I've got the same problem. Any news on this?

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,035)