cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
CVairavan
Level: Powered On

Flow not starting from PowerApps form occasionally

Hi

 

I have PowerApps for SharePoint list. When the user save the form, I want to start a MS Flow which send a notification to users based on the list values.  In PowerApps, SharePointForm OnSuccess method, I am initiating MS Flow. It is working fine for most of the occastion. But some time the Flow itself not starting. Even for same user, Flow starting in one occation and other it didn't

 

Looking for the reason for this strange issue.

 

 

 

4 REPLIES 4
Community Support Team
Community Support Team

Re: Flow not starting from PowerApps form occasionally

Hi @CVairavan 

 

Could you please share more details of your situation?

How do you configure your flow and what is the formula expression of the submit form icon?

Do you mean sometimes it works fine and sometimes not?

If it not works fine, could you please try to refresh the flow and then test?

 

Best Regards.

Yumia

 

CVairavan
Level: Powered On

Re: Flow not starting from PowerApps form occasionally

Hi Yumia

 

Thanks for the reply.

 

Find the formula on OnSucess of the SharePointForm. We want to start the MS Flow 'Prod_SalesFormReview' when user click on save.  It is working fine for most the occasion. But for sometime, the MS flow was not initiated at all.

 

Prod_SalesFormReview.Run(SharePointForm1.LastSubmit.ID); ResetForm(SharePointForm1);RequestHide();

 

Thanks & Regards

C Vairavan

Community Support Team
Community Support Team

Re: Flow not starting from PowerApps form occasionally

Hi @CVairavan 

 

Could you please change the formula expression as next and then test?

SharePointIntegration.OnSave=SubmitForm(SharePointForm1);Prod_SalesFormReview.Run(SharePointForm1.LastSubmit.ID)

SharePointForm1.OnSuccess=ResetForm(SharePointForm1); RequestHide()

 

Best Regards.

Yumia

CVairavan
Level: Powered On

Re: Flow not starting from PowerApps form occasionally

Hi Yumia
Currently the form in in Production. We see the issues in Production only. Can you explain the difference between both the code? As per my knowledge, OnSave will fire when user clicks on ‘Save’ button in the top.
In our case, we are saving the form in the button click changing the values of the few fields based on the button click.
Ex. We have option Save & Submit. ‘Save’ will just save the content to SharePoint list, in case ‘Submit’ will send notification to the reviewer. Based on the button, we setting value for ‘FormStatus’ column in SharePoint. When user clicks on ‘Save’, the FormStatus will be updated as ‘Draft’ and ‘Submiited’ in case of ‘Submit’ button.

Thanks & Regards
C Vairavan

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,370)