cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Form not going into group

I'm hoping this is a simple one.  I created some labels, buttons, and a form.  I want to have them be in a group together, but when i hightlight them all and select Group, the form is outside of the group.  I'm sure I'm just not doing something right, but I'm having a hard time remembering what that is.

12 REPLIES 12
K-A-R-L
Level 10

Re: Form not going into group

Hi @lumberjacklurch ,

Can you please make sure you select the Form before Grouping them.

 

Press and hold CTRL + Select Items (Label, Button, and Form)

SelectForm.jpg

 

Thanks,
K-A-R-L


If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Re: Form not going into group

@K-A-R-L

I did select it, but it is not in the group when PowerApps creates the it.

MikeLockwood
Level 8

Re: Form not going into group

I have found the same thing is happening for me.

Thanks,
Mike L.
aorphan
Level 8

Re: Form not going into group

Yes, we are also experiencing this same issue. This is a new issue that started happening recently. We have the "Enhanced group control" feature enabled. We have existing groups that contain forms. However when we attempt to add new groups, you cannot add forms. This breaks a lot of work we have put into our apps that use groups and is forcing us to use workarounds for the time being. Super frustrating!!

mfco
Level: Powered On

Re: Form not going into group

Also having this issue. I am selecting some controls + a form and when I group them, all the controls go into the group EXCEPT the form. 

I have existing groups with forms in them. If I copy and paste this group, the duplicated group contains all controls except the form.

 

Perhaps a bug was introduced in a recent PowerApps update?

Wondering if it may be related to the "Control Property Optimization" (preview) advanced setting being enabled by default now with no way to disable it.

aorphan
Level 8

Re: Form not going into group

I have created a support ticket for this, ID: 119072324003012.

aorphan
Level 8

Re: Form not going into group

I spoke to Microsoft this morning and raised the issue, they are aware of it. The support engineer said they will hopefully have it fixed in a month...

Highlighted
aorphan
Level 8

Re: Form not going into group

Just to inform anyone interested, I just received another reply from support:

 

I’ve checked with my product team once again regarding the issue you’re experiencing with the enhanced group control.

 

I would like to inform you that, our team is currently working on a fix, that is the reason some of the behaviors with the ‘Form’ in all container controls are blocked(which means the ‘Form’ control from being added to an enhanced group control are blocked).

 

Once the issue is fixed, it will behave as expected. I will update you on this, once I get any response from the Product team.

MikeLockwood
Level 8

Re: Form not going into group

Is there any update here as now I am seeing this is happening with DataTables as well.  This really creates additional work for managing positioning and visibility.

Thanks,
Mike L.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (6,373)