cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Owizardo
Level: Powered On

Gallery control broken?

Is anyone having problems with Galleries recently? For example, my PowerApps application is completely broken and getting the message: 

Uncaught ReferenceError: Label14__9Outputs is not defined

If I open my developper console in my chrome I see this error:

Uncaught ReferenceError: Label14__9Outputs is not defined

I traced it down to a gallery, removed the label but then it complains about something else in my gallery. The only way I was able to get pass this was removing the gallery all together. Tried recreating it from scratch about 10 times and keep getting errors that prevent. So can no longer use galleries ...

I went as far as recreating my application (that took me months by the way) from scratch and now my other application is acting up, for example vibility with the condition:

If(CountRows(Gallery.AllItems) = 0, false, true)


This seems to work on the Powerapps editor (After pasting it 2-3 times tough). But loading the application, nothing happens ...

 

Some help would be greatly appreciated.

 

 

EDIT: 

Scratch finally got the visibility to work, the probleme was with: 

If(CountRows(Gallery.AllItems) = 0, false, true)

Changed it to this:

If(CountRows(Collection) = 0, false, true)

 For some odd reason Gallery.AllItems always returns 0 ... again galleries seem very buggy at the moment. All this was working fine last week ... started today for me. 

21 REPLIES 21
K-A-R-L
Level 10

Re: Gallery control broken?

Hi @Owizardo,

 

suspect the browser cache should be related to this. Please delete your browser cache or use different browser.

 

Cheers

Owizardo
Level: Powered On

Re: Gallery control broken?

Hi Karl,

 

I cleared my cache and tried using IE edge and they both crashing on me at the moment. Did you have any other ideas?

K-A-R-L
Level 10

Re: Gallery control broken?

@Owizardo,

Have you tried using different browser other than IE and Edge like Chrome or Firefox? Have you tried changing the rendering settings option within the Advanced settings of App Settings (App settings-> Advanced Settings->"Improved app rendering" option).

Owizardo
Level: Powered On

Re: Gallery control broken?

At the moment I am using a company laptop which only allows Chrome and IE. Currently both of them are giving the same problems. Also the "Improved app rendering" was already enabled, swtich it off, same issue. Swtiched back on again, same issue. Removing the gallery in my initial screen fixes the errors. But like I mentioned even if i create a new screen with a whole new gallery, it causes the same problem. 

Community Support Team
Community Support Team

Re: Gallery control broken?

Hi @Owizardo ,

Could you please share a bit more about your issue?

 

I have made a test on my side, and don't have the "Uncaught ReferenceError" issue that you mentioned. Please consider turn on the "Experimental performance improvements" option within Advanced settings of App settings of your app, then re-load your app, check if the issue is solved.

 

In addition, I also made a test with the CountRows() function, and the issue is confirmed on my side. I think there is something issue with the Ouput of the Gallery1.AllItems formula. When you load your app, the Output of the  Gallery1.AllItems formula could not return in real time.

I would post this issue to my product team , if the issue is solved, I would reply here.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Owizardo
Level: Powered On

Re: Gallery control broken?

Hello, thanks for the tips, I activated the Experimental performance improvements and im still having the same problem. I tried to revert to previous versions, still the same issue. The only way to stop these errors is to remove the Galleries all together. I just cant re-add them at al.

 

Here is my app-id:
58efb53c-8de2-4dae-ab67-f91ae80b083f

Lugowskk
Level: Powered On

Re: Gallery control broken?

Got the same issue since this morning. Seems like a problem with last update. 

PowerApps Staff _Corey_
PowerApps Staff

Re: Gallery control broken?

@Owizardo @Lugowskk We have identified the issue and are working to address it.  I'll post again here as we know more.

Highlighted
vishchandra
Level: Powered On

Re: Gallery control broken?

All the controls are broken in my case.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (4,631)