cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
ck25415
Level 8

Gallery filter on SPO column name "Available" and type yes/no always shows false values

Hello,

 

I have a list with yes/no type column named "Available". If i filter gallery items on this column set to true, the gallery is showing items that have "no" in this column. I dont see this behaviour with the same column type but with a different column name like "Availability". Is this a bug or am I missing something?

 

Filter(test, Available = true) = does not work, return items with available = no

Filter(test, Availability = true) = Works

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Super User
Super User

Re: Gallery filter on SPO column name "Available" and type yes/no always shows false values

Both Availabile and Availability are Yes/No columns in SharePoint? 



--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

View solution in original post

4 REPLIES 4
Super User
Super User

Re: Gallery filter on SPO column name "Available" and type yes/no always shows false values

Both Availabile and Availability are Yes/No columns in SharePoint? 



--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

View solution in original post

ck25415
Level 8

Re: Gallery filter on SPO column name "Available" and type yes/no always shows false values

Hello @Jeff_Thorpe ,

 

Yes, both are Yes/No type columns in sharepoint. 

 

Correction: column names are Available and Availability 

 

Thanks,

Super User
Super User

Re: Gallery filter on SPO column name "Available" and type yes/no always shows false values

Apparently this is a bug and there is a planned fix but no ETA. They mention some workarounds like Available=1 but none of them can be delegated to the server. If you list is under 2k items you can increase the data row limit for non-delegable queries in the App Settings > Advance Settings and you should be ok.

 

https://powerusers.microsoft.com/t5/PowerApps-Ideas/Properly-filter-SharePoint-Yes-No-column/idi-p/1...



--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.
ck25415
Level 8

Re: Gallery filter on SPO column name "Available" and type yes/no always shows false values

Thanks @Jeff_Thorpe .

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 116 members 5,283 guests
Please welcome our newest community members: