cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DaniOrt
Level: Powered On

Gateway not found

Hi, i´m trying to connect to an on premise database. When creating de conection i´m not able to select my gateway. In "Gateways" option there is no gateways. I´ve installed one and singed in. I had a Power BI Gateway installed previously and seems to ver recognized by the Power Apps Gateway Installer.

 

In Power Bi everything is working fine but not in Power Apps.

In the log there´s only this entrance "Started the 'On-premises data gateway service'."

 

Thank you

 

PA_gateway.png

1 ACCEPTED SOLUTION

Accepted Solutions
tsapat
Level: Powered On

Re: Gateway not found

Uninstalling the PowerBI Gateway (old version) and installing the On-premise data gateway version seems to fix the problem.

View solution in original post

21 REPLIES 21
PowerApps Staff archanan
PowerApps Staff

Re: Gateway not found

Gateways are only supported in the default environment.

 

https://powerapps.microsoft.com/en-us/tutorials/gateway-management/

 

Could you double check to confirm you are in the right environment in PowerApps?

 

https://powerapps.microsoft.com/en-us/tutorials/working-with-environments/

DaniOrt
Level: Powered On

Re: Gateway not found

Thanks @archanan.

Yes, i´m in the default environment and still not working.

 

PowerApps Staff archanan
PowerApps Staff

Re: Gateway not found

Can you please share your session ID so we can look into this further?

 

Account -> Session details and copy paste the Session ID. Thanks!

PowerApps Staff archanan
PowerApps Staff

Re: Gateway not found

We are investigating this issue. I sent you a message as well. If you can email me your logs, it will help us investigate further.

tsapat
Level: Powered On

Re: Gateway not found

The same issue is also happening with our on-premises gateway, "no gateays installed" message appears in the "Gateways" even though the PowerBI gateway is up and running. Also, in the event viewer there is an error starting from the moment the data gateway was installed, with the following message:

 

Log Name: System
Source: Schannel
Date: 8/11/2016 5:23:56 μμ
Event ID: 36882
Task Category: None
Level: Error
Keywords:
User: NT SERVICE\PBIEgwService
Computer: ------
Description:
The certificate received from the remote server was issued by an untrusted certificate authority. Because of this, none of the data contained in the certificate can be validated. The SSL connection request has failed. The attached data contains the server certificate.

PowerApps Staff archanan
PowerApps Staff

Re: Gateway not found

We have seen some issues with PowerBI Gateways that were installed prior to our release of the PowerApps support. Could you please try these steps to see if that resolves the issue?

 

  1. Uninstall the gateway
  2. Download the updated/latest version
  3. Restore the Gateway using the recovery key

With your recovery key, you will be able to restore all your datsources and settings.

Highlighted
ssugar
Level: Power Up

Re: Gateway not found

I'm having the same problem.
Vicky_Song
Level: Powered On

Re: Gateway not found

@DaniOrt@ssugar@tsapat, Do you still have the same issue that not found the gateway even if tried @archanan's steps? 

tsapat
Level: Powered On

Re: Gateway not found

Uninstalling the PowerBI Gateway (old version) and installing the On-premise data gateway version seems to fix the problem.

View solution in original post

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (6,390)