cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
rvanderouderaa
Level: Powered On

HTTP Post with Powerapps input

Hi,

 

We are trying to send powerapps info, using microsoft flow, to an URI.

After creating the Flow with HTTP action, we want to connect the flow to the powerapp. When doing this we receive the following error:

failed to register service <GUID>

9CC988C4.PNG

 

http.png

 

8 REPLIES 8
yukonn
Level 8

Re: HTTP Post with Powerapps input

Hi,

 

I reported this issue on MS Flow. I do believe they haven't fix. Not only this issue.

  • No way to pass MS Flow Uri from PowerApps.(Data typemismatch and does not has convert function)
  • You cannot register your MS Flow if your MS Flow Choose value is come from PowerApp.

 

Regards

PowerApps Staff Samuel
PowerApps Staff

Re: HTTP Post with Powerapps input

Thanks for reporting this. To understand better, the first issue is that you can't use "ask in powerapps" for the URI? And for the second issue, what do you mean by "Choose value"?

yukonn
Level 8

Re: HTTP Post with Powerapps input

Hi,

 

      Yes, last time we can't ask powerapps for URI. Look like fixed but i will test again. Let say, we would like to get value from powerapps when flow has condition. Here is sample.

 

Flow Register Fail

 

 

 I'm also get same error that rvanderouderaa reported error.

berryvanesch
Level: Power Up

Re: HTTP Post with Powerapps input

Does anyone now if this problem is solved?

PowerApps Staff Samuel
PowerApps Staff

Re: HTTP Post with Powerapps input

This is actually a known issue we're trying to work out when an input from PowerApps is used directly in an condition block. You should be able to workaround it by clicking inside any other action to ask for PowerApps input, then use that "powerapps input" token inside the condition block. This will force the proper type for the input parameter (since condition inputs are untyped, powerapps client can't bind to these inputs). 

rvanderouderaa
Level: Powered On

Re: HTTP Post with Powerapps input

The initial problem is the unability to connect a flow with a HTTP component to a Powerapp. Is this a known issue also?

 

PowerApps Staff Samuel
PowerApps Staff

Re: HTTP Post with Powerapps input

Yes, this is the same root cause. The "Body" parameter of the HTTP action is untyped, so PowerApps doesn't know how to bind to it. Theoretically, you can do the same workaround as above to force the input to a particular type (probably a string), but that's less practical for part of an HTTP payload. We have work booked to figure out a better story for these cases. 

jovanC
Level: Power Up

Re: HTTP Post with Powerapps input

Hi Samuel,

 

Is the issue resolved yet? Is there a better way to get input from PowerApps to HTTP action in flow now? 

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (4,442)