cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Super User
Super User

IE Minimum Version?

Hello, 

 

What is the minimum required version of Internet Explorer? 

 

- I have some folks out there with IE 11.0.9600 who are unable to view my app. 
- I can open the app fine with IE 11.547.16299
- We can both open the app in Chrome

User receives error 

This app stopped working, try refreshing your browser

 

 

 

11 REPLIES 11
PowerApps Staff codyrplante
PowerApps Staff

Re: IE Minimum Version?

Hi ericonline,

 

Could you provide a session ID for the users not able to open the app on older version of IE11? Here is the documentation for getting the session ID: https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/get-sessionid

 

Thanks,

Cody

Microsoft Employee

Re: IE Minimum Version?

Hi @ericonline,

 

Sorry to hear you're experiencing trouble!

 

Here are the system requirements for PowerApps:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/limits-and-config

 

At the time of writing this, Microsoft Internet Explorer 11 (with compatibility view off) is the suported version of IE, for both PowerApps Studio and running apps. No mention of a minimum version of IE 11, however.

 

Edge and Chrome are recommended over IE for a better experience. That being said, you should still be able to use IE. As @codyrplante mentioned, a session ID could prove helpful (from one of the sessions that fail). You could also have those folks check if compatibility view is on. Curiously, have these users been able to open the app in their version of IE11 in the past?

- Paul C.
Software Engineer on PowerApps
Super User
Super User

Re: IE Minimum Version?

Hello @Paul_C

 

I have a group of 20 or so that cannot access my PowerApps. I just tried adding `powerapps.com` and `web.powerapps.com` using IE Compatibility Settings. No Go. 

 

Things changed after setting Compatibility. Instead of the original error message, user now gets a generic square in the middle of the screen!:

square.png

 

There is no place to grab a session ID. I DID right click, inspect source and found some very interesting info! I don't want to paste it here because there are various tokens and such in the source. 

 

Can someone from Microsoft please reach out to me via DM to cover this further? 

 

Thanks

Super User
Super User

Re: IE Minimum Version?

Hello @Paul_C and @codyrplante,

 

Interrogating the source a bit further from this "strange square" screen, I found the exact error message I have lined out as: 

 

  "WebPlayerErrorRunAppFailure":"This app stopped working. Try refreshing your browser.",

What is a WebPlayerErrorRunAppFailure and how do I fix it for those running IE 11.0?

 

Thank you

Microsoft Employee

Re: IE Minimum Version?

Hi @ericonline,

 

That looks really bad! I think you're supposed to have compatibility mode off for PowerApps to work, though, so that's probably why it broke so badly when turned on. Can you have one of the users who are experiencing trouble get us a session ID in their IE where they experience their original issue?

 

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/get-sessionid

 

With that information, we will be able to do some investigation on our end. In the meantime, of course, I recommend these users just use Edge or Chrome to unblock themselves (since you mentioned Chrome is working, that would probably be a good bet).

- Paul C.
Software Engineer on PowerApps
Super User
Super User

Re: IE Minimum Version?

Hi @Paul_C. Thanks for keeping this thread alive!

 

I hear ya on the "just use chrome" part.

 

Unfortunately

  • user base is largely non-technical
  • our intranet requires IE for many things (i know, right!)

There is not a way I can see to grab a session ID. The "gear icon" is not available on the error screen. Is there a secret squirrel way to grab this elsewhere?


Thanks

 

noSessionID.png

Super User
Super User

Re: IE Minimum Version?

(bet its hiding behind that "More", isn't it) 🙂

 

I'll reach back out to the user. Its very difficult to get ahold of them as they are spread out across the country. This issue has a large enough reach they may be more willing. 

 

I'll touch base as soon as I can. 

Highlighted
Microsoft Employee

Re: IE Minimum Version?

Ah, now I see what you mean about the session Id! I don't remember for sure, but I do think it might be behind the "more". If so, it looks like we should update our documentation to include that case. 😉

 

I appreciate you reaching out for the session Id!

- Paul C.
Software Engineer on PowerApps
Super User
Super User

Re: IE Minimum Version?

Hello @Paul_C

 

I finally tracked down this user (in Badlands, SD!). Still has issue when using IE. 

 

Session ID: ca0c55bb-ae26-4111-a981-81bebe7d4d55 . 

 

Please advise when you can on what the fix might be and we'll try to implement. 

 

Thank you

 

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (6,531)