cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
aelek
Level: Powered On

Importing Custom API as Connector Failure

I'm trying to create custom connector by importing OpenAPI specification which I'd previously successfully imported to Logic Apps as a custom connector.

Specification is picked up alright and all actions pass validation, however, when I try to save the connector, I get the following message.

 

Encountered internal server error from Azure Resource Manager. The tracking Id is '00e8ba0b-e862-4bd9-a8d9-0f5042b0d841'.

 

When I try to import connector directly from API definition in Azure Portal, I get timeout message

 

Failed PowerApps Custom API creation. Error Details: The gateway did not receive a response from 'Microsoft.PowerApps' within the specified time period.

 

Neither error message is really helpful and I don't know what to do with that Tracking Id so any help is appreciated.

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
PowerApps Staff davidme
PowerApps Staff

Re: Importing Custom API as Connector Failure

Here's an update:

 

The error seen in server logs is: InnerMessage : Violation of UNIQUE KEY constraint 'IX_Tag__Id'. 

 

The partner team continues to investigate the root cause and potential fixes, but suggests the following as a workaround:

 

"Strip incoming swagger file of any tags if you don’t need them"

 

Let us know if the workaround helps to unblock you here.

 

Thanks

-David

 

View solution in original post

3 REPLIES 3
PowerApps Staff davidme
PowerApps Staff

Re: Importing Custom API as Connector Failure

Thank you for reporting. We are investigating with a partner team the root cause of the errors you have encountered here.

 

Thanks and regards

-David Messner

PowerApps Staff davidme
PowerApps Staff

Re: Importing Custom API as Connector Failure

Here's an update:

 

The error seen in server logs is: InnerMessage : Violation of UNIQUE KEY constraint 'IX_Tag__Id'. 

 

The partner team continues to investigate the root cause and potential fixes, but suggests the following as a workaround:

 

"Strip incoming swagger file of any tags if you don’t need them"

 

Let us know if the workaround helps to unblock you here.

 

Thanks

-David

 

View solution in original post

aelek
Level: Powered On

Re: Importing Custom API as Connector Failure

Hi, David.

 

The suggested workaround works and after removing all tags from openAPI specification, import succeeds. Hope this gets fixed in the future, but for now the mere fact that import works is brilliant. Smiley Happy

 

Thank you very much for your help!

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

Top Kudoed Authors
Users Online
Currently online: 263 members 5,360 guests
Recent signins:
Please welcome our newest community members: