cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
hpkeong
Level 10

LoadData Not Working on Android

Hi PG:

 

As reported couple of months ago, LoadData / SaveData did not work on Android Phone (never tested on iPhone) but work on Windows 10, and today, I re-write to test again a simple userid table but still fail on Android Phone.

 

My scenario:

- Open Apps on Android Phone (with Connection.Connected), so that I can cache (with SaveData) for the FIRST TIME.

- Then, I quit the apps, off the internet connection, and reload the apps

(a) in Win 10, it works and started to load (after about 10 seconds, a small data, 3 rows)

(b) in Android phone, nothing showed up

 

When I connect internet again, everything works as normal.

 

So, I can confirmed that LoadData and SaveData are NOT FIXED after several months.

 

I wish PG can test on a Small Data on ANDROID PHONE only to reproduce.

 

Best wishes and Merry Xmas.

 

hpkeong
7 REPLIES 7
Community Support Team
Community Support Team

Re: LoadData Not Working on Android

Hi @hpkeong,

 

Which version is your PowerApps Mobile app?

Which OS version is your Android phone?

Further, could you please show a bit more about your LoadData() function and SaveData() function?

 

I have made a test on my side and don’t have the issue that you mentioned. When I am online, the PowerApps app display as below:12.JPG

When I am offline, the PowerApps app display well as below:11.JPG

 

My Android phone OS version is 7.1.1 and My PowerApps Mobile app version is 2.0.681. The latest version of PowerApps Mobile app is 2.0.733, you could consider take a try to update your PowerApps Mobile app to the latest version and check if the issue is solved.

 

In addition, please check and see if the following article would help in your scenario:

https://powerapps.microsoft.com/en-us/blog/build-offline-apps-with-new-powerapps-capabilities/

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
hpkeong
Level 10

Re: LoadData Not Working on Android

Hi @v-xida-msft

 

Thanks for quick response.

I am using 2.0.733 (Android 6.0).

[I started this new version since testing from Hockey Apps]

 

The code is pretty straighforward

If(Connection.Connected,

   ClearCollect(MyID, TableID),

   LoadData(MyID, "MyTable");

SaveData(MyID, "MyTable")

 

As I mentioned, PowerApps on Win 10 - Works perfectly but nt Android.

 

For Android Phone, in fact, when I Opened the Apps with Internet.Connected, 

the ClearCollect works and display MyID data into a Gallery (I purposely added in to check, using MyID), and then it save into MyID. Subsequently, I turned off WiFi, Mobile data, and continue to use without problem and MyID still showed.

 

BUT, When I quit the apps and open again, then this DID NOT LoadData from MyID and in fact it should as it was already Saved (as of the last statement in the above coding function).

 

So, would you tried to repeat my way?

- Open apps with Connection,Connected

- Off the connection

- Quit the apps

- Open again...if you can see the DATA in Androidm that means I am totally in trouble with my phone / code.

(just curious, it works in Win 10 Apps....)

 

TQ

hpkeong
Super User
Super User

Re: LoadData Not Working on Android

Hi @hpkeong

 

Just for info, I tested the SaveData and LoadData functions on my Android device and it works for me.

 

I'm using a slightly older version - v2.0.640 (Android 5.0)

 

The source data that I used was a large spreadsheet, and I was able to save and load 500 records with these functions.

 

Supposing you add a new screen to your app and add a new label with the formula:

 

CountRows(MyID)

 

If you navigate to this screen after calling the LoadData function while offline, do you get a non 0 row count?

 

This might help determine whether this is a screen/gallery display problem on Android, rather than a problem with the LoadData function.

 

Hope you find a solution to your problem!

Highlighted
Microsoft Employee

Re: LoadData Not Working on Android

@hpkeong

 

I'm curoius about the use of the Connection.Connected. We've had another issue reported where the Connection status isn't working in some scenarios on Android. We're finding it hard to reproduce however. Can you please let me know the following so that I might have a better idea if this is related.

 

  • Can you add a label with the formual of Connection.Connected, and verify that its the correct value
  • Add another label with the formula IF(Connection.Connected, "connected", "not connected")  (ie validate your IF condition is being executed, when using that condition)

 

Thanks

 

JeffSmith215
Level: Powered On

Re: LoadData Not Working on Android

Can also confirm that a simple "Save Data", "Load Data" doesnt work on the PowerApps Android client (3.18043.21) on my Galaxy S8 (Android 8).  Same code executes flawlessly on my iPad and iPhone.

 

It "appears" as if it is the Save Data portion that is failing (and therefreo nothing to load in teh load data command)....Android permissioning perhaps??

 

😞

 

Microsoft Employee

Re: LoadData Not Working on Android

Thanks we've logged a bug to track this.

 

#2425878

 

 

JeffSmith215
Level: Powered On

Re: LoadData Not Working on Android

New release of the PowerApps Android client today and SaveData / LoadData now working!!!!

 

Yay!

 

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 328 members 6,250 guests
Please welcome our newest community members: