cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
emh
Level 8

Message is: Server error. Server response: Not a valid connector response…

Hello,

 

I am receiving this error message when submitting a form. The sql connector works fine in other apps and other parts of this app. Only when submitform is called does this message appear.

 

Any help is greatly appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions
GerbenA
Level: Powered On

Re: Message is: Server error. Server response: Not a valid connector response…

I ran into the same error message when trying to update a table with a trigger. After removing the trigger (Smiley Sad) it all worked as expected. Could it be that your table in PRD has a trigger where dev/test do not?

View solution in original post

6 REPLIES 6
Community Support Team
Community Support Team

Re: Message is: Server error. Server response: Not a valid connector response…

Hi @emh ,

Could you please share a bit more about the error message?

Do you mean that the error message appear only when the SumitForm() function is executed?

 

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned.

 

Please consider remove the SQL connection from your app, then re-create a new connection to your SQL Table from your app, then try it again, check if the issue is solved.

 

In addition, if the issue still exists, as an alternative solution, please consider use Patch function to submit your form data instead of SubmitForm function. Please set the OnSelect property of the "Submit" button to following:

If(
   EditForm1.Mode = FormMode.New,
   Patch(
            '[dbo].[YourSQLTable]',
             Defaults('[dbo].[YourSQLTable]'),
             {
               Column1: DataCardValue1.Text,
               Column2: DataCardValue2.Text,
               Column3: DataCardValue3.Text,
               ...
             }
   ),
   Patch(
             '[dbo].[YourSQLTable]',
             BrowseGallery1.Selected,                 /* <--I assume that you used a Gallery to list all records of your SQL Table in your app */
             {
                  Column1: DataCardValue1.Text,
                  Column2: DataCardValue2.Text,
                  Column3: DataCardValue3.Text,
                   ...
             }
   )
)

Note: DataCardValue1, DataCardValue2, DataCardValue3, ... represents the Data Card values in your Edit form.

 

Please consider take a try with above solution, then check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
emh
Level 8

Re: Message is: Server error. Server response: Not a valid connector response…

Hello,

 

I appreciate your prompt feedback. Since there are 43 datacards, it has taken some time to put the Patch function together. It works in the DEV environment, but so did the SUBMITFORM. Before the app may be promoted to TEST and PRODUCTION, the id_num of the newly written sql record is needed. With the SUBMITFORM, I was able to retrieve the id_num (IDENTITY column in sql table). I cannot seem to do this with Patch. 

emh
Level 8

Re: Message is: Server error. Server response: Not a valid connector response…

Quite simply, this errors when the user clicks the button which invokes the SUBMITFORM function. This problem is only experienced in the PRODUCTION environment. The app works fine in the DEV and TEST environments. 

 

I changed the SUBMITFORM to Patch. Again, it works fine in DEV and TEST. In PRODUCTION, the same error message.

GerbenA
Level: Powered On

Re: Message is: Server error. Server response: Not a valid connector response…

I ran into the same error message when trying to update a table with a trigger. After removing the trigger (Smiley Sad) it all worked as expected. Could it be that your table in PRD has a trigger where dev/test do not?

View solution in original post

NoumanQ
Level: Powered On

Re: Message is: Server error. Server response: Not a valid connector response…

Same issue being faced on our end aswell. It seems this issue has been going on for a long time.

emh
Level 8

Re: Message is: Server error. Server response: Not a valid connector response…

The underlying table may have a trigger on it. PowerApps does not allow for Azure SQL Server triggers.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (5,576)