cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Super User
Super User

NO DATABASE FOUND: Error when trying to create a new app

We setup a new PowerApps Environment (dev) a couple months back and have been guiding all users to move their apps FROM default TO dev.

Scenario:

  • Yesterday user ported all of his applications from DEFAULT to DEV (nice work!)
  • Today user went in to create an app in DEV and received the error below “No Database Found”
  • I verified user selected Canvas (not Model-driven)
  • I went into DEV and was able to create a new Canvas app with no issue

image.png

Something changed overnight in users permissions. What happened here? 

 

ALSO, I'm the admin for the DEV env. I verified there are NO Model-driven apps created in this env yet the permissions are showing as handled by Dynamics. What is going on here? 

image.png

Thank you

4 REPLIES 4
Community Support Team
Community Support Team

Re: NO DATABASE FOUND: Error when trying to create a new app

Hi @ericonline ,

Have you set up a Common Data Service data source within your DEV Environment?

Have you assigned appropriate role of this DEV Environment to your end users?

Does your canvas app using CDS Entity as data source?

 

I have made a test on my side, and don't have the issue that you mentioned. Please check if you have set up  a Common Data Service data source within your DEV Environment already. If not, please create a Common Data Service database within your DEV Environment.

 

In additon, also please check if you have assigned proper security role of your DEV Environment to your end users. You should assign Environment Marker role of your DEV Environment to your end users at least.

 

Also please check if your end users have proper License to access PowerApps, and the license is not expired.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Super User
Super User

Re: NO DATABASE FOUND: Error when trying to create a new app

Hi Kris,

 

We did not setup a CDS database for this environment because we don't run any model-driven apps. Unfortunately, "something" triggered the security for this environment to be "pulled into" Dynamics. When this happened, all users of the environment lost permissions or started having errors like the one above. Not good.

 

There are no logs to review to determine why/how this event occurred nor how to prevent it in the future. 

Administrator
Administrator

Re: NO DATABASE FOUND: Error when trying to create a new app

Hi @ericonline are your users still experiencing this issue?

 

@TopShelf-MSFT 

Highlighted
Super User
Super User

Re: NO DATABASE FOUND: Error when trying to create a new app

Yep. For some reason, our DEV env is a mess. 

Went from "Shared with organization" and managed in PowerApps to "Shared only with Admins" and managed by Dynamics security model. No opt-in, everyone but admins lost access. 

Luckily, it was a newer dev env with only a handful of active users but I still can't find a way to get them access. They all have "Environment Maker" and "Common Data Service User" roles checked...

 

I think we have a ticket open somewhere..

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors
Users Online
Currently online: 201 members 5,564 guests
Please welcome our newest community members: