cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
namurdock
Level: Powered On

Navigation property Attributes With Id = xxx does not exist on Metadata Entity with ID = xxx

Our embeded canvas app is working flawlessly in our development environment. If i export the solution and import into our UAT environment then the app loads find and functions as expected. Except for navigation from my gallery to the read only form, this error is displayed, there are no onvisible updates:

 

Annotation 2019-05-09 171641.png

1 ACCEPTED SOLUTION

Accepted Solutions
Helpful2
Level: Powered On

Re: Navigation property Attributes With Id = xxx does not exist on Metadata Entity with ID = xxx

Hi @namurdock,

 

To fix this, you need to enable the "Improved Data Source Experience for Common Data Service" preview setting.

Steps:

  1. Remove your existing Common Data Service data sources
  2. Turn on this switch (“Improve data source experience and Common Data Service views”)
  3. Re-add your Common Data Service data sources using the new data source selection experience.

View solution in original post

8 REPLIES 8
Community Support Team
Community Support Team

Re: Navigation property Attributes With Id = xxx does not exist on Metadata Entity with ID = xxx

Hi @namurdock ,

Could you please share more details about the Navigation formula within your app?

Do you pass parameters from one screen to another screen using the Navigate() function?

 

I have made a test on my side, and don't have the issue that you mentioned.

 

Please consider remove the CDS Entity connection from your app, then re-add a new connection to your CDS Entity from your app, then try your Navigate formula again, check if the issue is solved.

 

In addition, an alternative solution, please consider set a global variable (using Set function) to store the value you want to pass from one screen to another screen rather than use Navigate() function. Then you could reference the global variable everywhere within your app.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
namurdock
Level: Powered On

Re: Navigation property Attributes With Id = xxx does not exist on Metadata Entity with ID = xxx

The OnSelect from the Gallery (AvailableVehiclesGallery) is:

 

Navigate(VehicleDetail);

Then the detaSource for the read-only field is:

 

Vehicles

and the Item is

 

AvailableVehiclesGallery.Selected

There is no OnVisible code on the VehicleDetail screen at all.

 

I'll give the suggestions a go and report back, hopefully later today.

namurdock
Level: Powered On

Re: Navigation property Attributes With Id = xxx does not exist on Metadata Entity with ID = xxx

Update:  I have tried setting the global variable as suggested. then using that instead of the "Gallery.SelectedItem". But i still get the same error.

Community Support Team
Community Support Team

Re: Navigation property Attributes With Id = xxx does not exist on Metadata Entity with ID = xxx

Hi @namurdock ,

Do you deploy an app with a Solution from one Environment to another Environment?

Which Solution to you import to your Target Environment (UAT)? Managed Solution or Unmanaged solution?

 

When you deploy an app within a Solution from one Environment to another Environment, the connection within your app created within previous Environment would be invalid within the new Environment.

On your side, you should create a new connection to the same Entity within your target Environment from your app, then re-publish your app, check if the issue is solved.

Note: I assume that you have deployed the same CDS Entity from your source Environment to the Target Environment successfully.

 

The user @dileep_gopalakr has faced same issue with you, please check my response within the following thread:

https://powerusers.microsoft.com/t5/General-Discussion/Picking-lists-are-not-working-if-the-app-depl...

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
namurdock
Level: Powered On

Re: Navigation property Attributes With Id = xxx does not exist on Metadata Entity with ID = xxx

Hi @v-xida-msft ,

 

I am deployment the solution from DEV to UAT as a managed solution.

 

I have removed and re-added the connection in UAT and changed nothing else but get this error when i try to publish:

 

The canvas app '[Embedded] Available Vehicles' was installed as part of a managed solution and direct editing is not supported at this time.

Session ID: ba828b7c-53c8-40ec-b7b8-00bfa3ba8584

Which confirms my thoughts that these things should "just deploy" with no post deployment steps event when changing environment.

 

Deploying as an unmanaged solution is not an option here as the solution (prior to the introduction of a canvas app) already exists as managed and so cannot go back to unmanaged.

 

The limitation listed here:

 

https://docs.microsoft.com/en-us/powerapps/maker/common-data-service/use-solution-explorer#known-lim...

 

  • Canvas apps must be opened after a solution is imported to update the connections.

 

Basically renders managed solutions useless.

 

 

namurdock
Level: Powered On

Re: Navigation property Attributes With Id = xxx does not exist on Metadata Entity with ID = xxx

Quick bump on this topic. Given the managed solution piece, is this a bug that we will just have to wait for a fix for?

Helpful
Level 8

Re: Navigation property Attributes With Id = xxx does not exist on Metadata Entity with ID = xxx

Would be great to see a resolution to this.  App has been working just fine publishing as managed solution from DEV -> TEST and now it's getting this error.

Helpful2
Level: Powered On

Re: Navigation property Attributes With Id = xxx does not exist on Metadata Entity with ID = xxx

Hi @namurdock,

 

To fix this, you need to enable the "Improved Data Source Experience for Common Data Service" preview setting.

Steps:

  1. Remove your existing Common Data Service data sources
  2. Turn on this switch (“Improve data source experience and Common Data Service views”)
  3. Re-add your Common Data Service data sources using the new data source selection experience.

View solution in original post

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (4,928)